Need Help Recovering Data from 2TB My Book Live!

I’m an amateur with data recovery, but I’ve seen a lot of helpful advice on these boards.  I’m hoping that someone can help me recover some important data on a busted 2TB WD Caviar Green drive that came out of a 2TB My Book Live that stopped connecting.   I tried directly connecting it to my computer (instead of through the network), but it still could not be detected.  The drive still spins, but there is an initial spin, a few clicks, then a slow wind down.  This repeats like it’s trying to read the drive but is unable to.  Not sure if my partition table is damaged or what the problem is.  After getting an RMA number, I got permission to remove it from the enclosure so that I can try to connect with a USB to SATA adapter. 

I’ve tried two adapters - one that has worked for other drives in the past (Sabrent USB-DSC5) and one brand new one (Uspeed USB 3.0 to SATA) - but neither was able to get the drive recognized.   It doesn’t show up in Windows or Linux OS’s and it appears to be unmountable so I can’t use teskdisk or other recovery programs. 

Here are the steps that I’ve taken with the results:

  1. Booted with Ubuntu and also Gparted, but the drive was still not recognized.
  2. Used R-linux, R-Studio, and Data Internals Linux Reader, but none of them have been able to read the data.  The drive is visible when using the Sabrent USB-Sata converter, but it looks like unallocated disk space or an unmounted drive.  I’m unable to run any scans.  
  3. Ran WD Data Lifeguard Diagnostics and it detects the drive, but has no information on the drive.  When I run a thorough scan, it so that there are bad sectors.  When trying to repair, I get an error.
  4. Under Windows Disk Management (running Windows 7 x64), it is visible as an “unknown” physical drive, and no initialization is possible.

I don’t think the issue is coming from the drive not being jumpered properly (there are currently no jumpers), but who knows.  ANY help that anyone can provide would be greatly appreciated!  Before I get blasted for not having a backup - this WAS the backup to my backup, which happened to die 2 weeks before this one.  I didn’t have time to get a new one yet - guess that’s what I get for procrastinating!

Hello, if you hear a clicking sound the internal hard drive might be faulty. In that case there is not a lot you can do. Just in case, you can try using a data recovery program like recuca or testdisk.