MyCloud, don't like My Passport? WD Sync

Good day to you all,

I have some My Passport’s with lots of photo’s. I bought MyCloud 6TB to backup and I would like to synchronise MyCloud when I make changes on My Passport.

I placed a folder with photo’s in the folder WD Sync in My Cloud (folder is in me as user).

I’ve been trying several things but I can’t figure it out how te WD Sync folder synchronises with My Passport.

Who can help me?

Thanks a lot.

Best regards,

(the Netherlands)

See the User Manual Chapter Four.

Visit Support>Downloads>WD Sync for Windows, use link below.

Applicable Products
My Cloud, My Cloud Mirror Gen2, My Cloud Mirror, My Cloud DL2100, My Cloud DL4100, My Cloud EX2, My Cloud EX4, My Cloud EX2100, My Cloud EX4100


thank you very much cat0w,

I placed a copy of a folder on MyPassport into Wim > WDSync (Wim is my username).

first test:
I closed MyCloud
I removed some files (jpg) from the folder in MyPassport
I restarted MyCloud and was waiting for some kind of synchronising, but did not happen.
I’m looking for the button to synchronise but can’t find it.

second test:
I removed My Passport from USB.
I deleted some files (jpg) from the folder in WD Sync
I connected My Passport on USB again.
I am waiting for some kind of synchronisation, but did not happen.
Now I’m looking for the button how to synchronise.

I also can’t find WD sync view menu with te logo icon.

What am I doing wrong?

If you haven’t already done so you may want to read the WD My Cloud User Manual, in particular Chapter 4, Backing Up and Retrieving Files, Synchronizing Your Files and Folders with WD Sync. It explains how to setup and configure WD Sync to sync files from your computer to the My Cloud.

Yes I did, but even then it seems to be to difficult for me.
I tried at first on a Macbook, then on a Windows 10 machine and after seen the video on my Macbook.

Now copying a folder ‘movies’ to the WD Sync folder (all on Mac) but it stops at 999.0MB of 7,8GB.

Will place my improvements here … :wink:

Note the 999mb copy issue (to the My Cloud) is being experienced by others…

Further if using El Capitan on the Macintosh there are some problems with that too when using the My Cloud:

Hello Bennor,

Thank you for this information. Step by step I will try to understand everything. First the Sync item.
It’s not clear to me how sync works with certain folders on a USB external drive like ‘MyPassport’.
Does the WD Sync recognises the folder if I connect the USB drive again later? Is sync in both directions?

I don’t know if the WD Sync program will recognize/remember the folder on a USB drive if that drive is removed and remounted at a later time. Only thing I can suggest is to give it a try and let us know what happens.

On the question of bi-directional syncing with the WD Sync program. Some have reported that it does not sync in both directions for them. However when I setup the WD Sync software to test the software, it did do bidirectional syncing for me. You can read a bit more on the bidirectional syncing in the following thread including my post in that thread about bidirectional syncing with WD My Cloud working for me.

Were you able to install WD Sync on your Passports? That is why I put the list of Applicable Products in my post. You will find that same list on the support site. From that list I say it does not work with Passports.

The following comes from chapter four in the User Manual; File synchronization is accomplished by:  WD Sync software installed on each computer.

Watch this video,

Also look at this, look at Helpful Topics>How To Setup & Use WD Sync

As far as I know, WD Sync runs on computers, not on the MyCloud. ‘WD Sync for Windows’ being something of a clue here. WD Sync is not installed on MyCloud or MyPassport drives.

And WD Sync is supposed to work with the HDD of a PC. MyPassport drives are connected to a PC via USB, so, essentially, should look like an HDD on the PC.

So I’d say it’s not unreasonable to expect WD Sync to work with MyPassport drives connected to a computer.

If it doesn’t, then look elsewhere at more versatile Sync/backup programs, such as FreeFileSync, which will work with the MyCloud, with the PC’s HDD, with USB HDDs attached to the computer, etc.

OK this is quick and dirty with some screen captures explaining how the WD Sync program works with external USB hard drives. Sorry for some of screen caps having black bars over some content, had to block out some of the information on those screens. Note: While these steps / actions worked for me, your experience may be different.

Hardware / Software Used:
Windows 10 Pro Version 10.0.10586 Build 10586
Windows File Explorer
WD Sync Version 1.1.5731
WD My Passport 320GB USB External Hard Drive (WD 3200BEV)
My Cloud 1T Firmware Version 04.04.01-112

General steps:
Right click on WD Sync icon in task tray. Select “Settings…” and the WD Sync Settings screen will appear.

Click the “Add…” button and the Local folder browser dialog box appears. Select a local folder on the external USB drive (WD My Passport drive used in this example) that is connected to the computer. For this example I selected the Nexus 7 Factory Images folder. then select the “Select Folder” button.

In the Device Folder Browser window select a folder location (or create one via the “New Folder” button) on the My Cloud where the files will be synced too. For this example I selected the Passport Sync Folder. Then select the “Select Folder” button.

The WD Sync Settings screen should appear again, this time indicating the new folder sync that has been created. Select the “Close” button.

WD Sync program should now start to sync the contents of the folder on the external USB drive over to the folder on the My Cloud.

If one right clicks on the WD Sync icon in the task tray it should indicate the files it is syncing to the My Cloud. Sometimes it may take a number of minutes before the sync begins if there is a large number of files to be sync’d to the designated folder on the My Cloud.

Ejecting and reinserting the external USB hard drive:
I did eject the external USB hard drive (WD Passport drive) and after a few minutes Windows 10 threw up the following message.

I then rebooted the Windows 10 computer. And Windows 10 threw up the following WD Sync warning immediately after booting to the desktop. This message was followed by the preceding screen capture message by WD Sync indicating the drive/folder was missing.

I plugged the external USB hard drive (WD My Passport) back into the computer. No message by WD Sync was presented. I then copied some files from my computer into the folder (Nexus 7 Factory Images in screen captures above) on the external USB hard drive (WD My Passport) that was being monitored by WD Sync and the WD Sync program synced the files to the designated folder on the My Cloud.

Bidirectional Syncing:
I then subsequently copied several files to the folder (Passport Sync Folder in the screen captures above) being monitored on the My Cloud by the WD Sync program and those files were subsequently copied to the external USB hard drive (WD My Passport) designated folder. Note: there was a noticeable delay of a few minutes before the files were copied from the My Cloud to the external USB hard drive (WD My Passport), I assume its because the WD Sync program was scanning and comparing the files in both locations before doing the bidirectional copy from the My Cloud to the external USB hard drive. I experience this same delay when files get synced by the WD Sync program to a local folder on my computer’s hard drive.


  • One can sync from an external USB hard drive to the My Cloud using the WD Sync program.
  • The WD Sync program will bidirectional syncing “new” files from the My Cloud to the external USB hard drive.
  • If one ejects the external USB hard drive, the WD Sync program will display error messages indicating the drive is missing.
  • The WD Sync program will continue to sync from the external USB hard drive once that external hard drive has been reinserted back into the computer.
1 Like

Hello Bennor,

Your reply, your research was very helpful for me. I tried it myself on a Windows 10 machine and it worked very well.

On my Macbook I did not succeed yet but that was also because of the fact that the WD USB drive is formatted as NTFS.

Thanks a lot for your help Bennor and of course also other responders. GREAT!

the Netherlands