MyBookLive failing to wake for scheduled safepoint


I wonder if anyone can help me. I have a 2tb and a 3tb MyBookLive drive and the 2tb source drive is scheduled to take an automatic safepoint on the 3tb target drive daily.

However when both drives are asleep (always) the source drive is failing to wake for the scheduled safepoint so it is being missed. There is no notification it just does not wake to take the safepoint.

I have tried extensive combinations of router and network switches to no advantage. If the source drive is already awake it successfully wakes the target drive and takes the safepoint and, obviously, if both drives are awake then there is no problem either.

I have also tried swapping the source & target drives in case there was an issue with the hardware but the behavior is identical, the source drive simply fails to wake when the schedule requires.

I am currently running through a netgear unmanaged gigabit switch but as mentioned I have tried this through different switches, routers and hubs without success. WD simply tell me:

In this case if the safepoint is not occurring as expected i would recommend you to disable the sleep timer on the units by going to dashboard > settings > system > energy saver and then try again, the drive should be responding even if it is sleeping, however in some cases based on the configuration of the router it might not receive the command, so i would recommend you to try this.

However a specific requirement of mine is to have the ability to sleep and, apparently, wake and backup automatically so this option is a non starter for me.

Both drives are sleeping and waking perfectly for all other applications (media player’s, audio streaming, PC request) so there is not an issue elsewhere.

Any ideas please?

Is there an application you can run to wake the drive a few minutes before the safe point?

WD have replied further now . . .

The issue has been reported and we’ve seen similar situations before, at the moment there’s no solution for this particular issue and it seem to be related with something in the firmware of the drive which is not allowing the drive to wake up, in some cases as i was saying it could be resolved by disabling the sleep timer, however in your case that will not take care of it, we do apologize for the inconvenience this might cause.

So it woulkd seem this is a known, if unusual, fault and hopefuly a firmware upgrade will be forthcoming in the near future . . . . . . .

This will be fixed in the upcoming firmware release.

Happy to report that the latest firmware update has fixed the issue, auto backup now working well and coonsistently (so far 3 tests) from sleep.

Need to monitor as not 100% sure drives are returning to sleep mode for more than a few miniutes after the backup. Will check this as I need to ensure the network is fully inactive, but for now many thanks WD :slight_smile:

Yep - totally fixed - rogue network monitor on my mobile was waking them up again . . . . . . . . . .

Once again, many thanks for sorting out this issue :slight_smile:

Ah…  The drive falling asleep stops cron from working.  :robotindifferent: