My Passport Ultra not reading after using it for very long

Hi,

I have been using this hard drive for around 2 years and it’s been working perfectly. Recently, I wanted to transfer some files over to my other computer and it worked. After moving the files and transferring the Hard disk back into my main work computer, it cannot be read. I tried disk utility but I still cannot find it. My main work computer is a Mac Pro.

Funny enough, if I were to test it on my Macbook Pro, it can be read perfectly fine. To further troubleshoot this issue I have tried:

  • using another hard drive (not WD) on my Mac Pro and it worked. (Not a hard drive reading issue)
  • taking out everything else except the WD hard drive, and still did not work (Not a Mac Pro power issue)
  • reading it on the Macbook Pro (contents are not corrupted)

I don’t know what else to do, as I need that hard disk on my main computer, as there are sound libraries in there, that might have licensing rights tied to that hard drive.

Please help, thank you!

Hi gideonlim,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support