My Passport Ultra doesn't mount on Mac anymore

So,I  bought this WD My Passport Ultra HD back in September to use to archive my photography using my iMac. Worked fine until yesterday when I accidentally removed the cable while it was mounted on the desktop.

Now it doesn’t mount any more, and I can not access my irreplaceable archive. I have tried the various suggestions but it is not mounting. This seems to be a very common theme with these WD drives, they seem to be very delicate. I wouldn’t expect any product to react like this after a few months use.

So, any suggestions please?

Welcome to the Community.

Have you tried searching for clues using your Mac’s built-in Disk Utility diagnostic tool?

http://wdc.custhelp.com/app/answers/detail/a_id/1362/

Thanks for the reply. Yes, I have used Disk Utility and found the disc, though the part I need is not mounted. I have run diagnostics that suggest it’s ok. But it still doesn’t mount, and more importantly, it has files on it I need urgently.

I can’t believe that this seems to be such a common experience with these WD external drives used with Macs, and the official answer seems to be ‘the partition may have become corrupted’. if you pay money for a product, you expect it to do a job and be fit for purpose - this WD drive certainly hasn’t been that.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

Support by Country
http://support.wdc.com/country/index.asp

Hi there,

I’ve had this problem several times with my My Passport. It’s a different device, but the same solutions may apply.

  1. Let it stay plugged in for a long time, possibly overnight. Sometimes, when the device is improperly ejected, it just takes a while to reestablish its connection with the mac somehow. I have no idea how this works, but in every instance the HD has eventually re-mounted on its own if I left it plugged in long enough.

  2. Sometimes it appears that the device is not accessible, but in fact it just isn’t displaying in th left sidebar of finder windows for some unknown reason. In this case, if you go to disk utility and you do see it there, you may see at the bottom: "

Mount Point : /Volumes/MyPassport. If you click on the /Volumes/MyPassport link, it will take you to the files, and you can drag and drop the folder back into your favorites bar.