WD My Passport Ultra has suddenly stopped mounting!

Hi, I’ve been using My Passport since I received it with no problem. I used it yesterday, however, today it wont mount. I have a MacBook Pro running OS X 10.11.1. I’ve looked at Disk Utility, and I can see the Virtual CD (see link to screen grab http://cl.ly/image/0M372Q3k0s1Q ), but the mount button is greyed out. Please help!


Have you try using the unit on a different PC?

Are you able to test using a different USB cable?

I have tried another USB 3 cable. Same thing. I have just been reading on this forum that other people are having problems when using El Captain (OS X 10.11), which is pain. However, I successfully got access to the HD, quite by accident, the following way: I rebooted the Mac, then at the login screen I plugged in the HD, then logged in and ‘alas’ WD Unlocker mounted and I could use the HD like usual. However, when I unmount and re-mount I have the usual problems. Go through the reboot process again and it’s fine, until I un-mount. Just flippin weird!!! But still not ideal at all.

I tested with a new cable, as well as on my iMac to no avail :frowning:

I’ll try it. I have an appointment with Geek Squad for them to try and recover the images.