My Passport Stopped Mounting On OS X 10.11

Hi All,

Recently my external My Passport for Mac hard drive stopped mounting on my MacBook – my laptop is running Mac OS X 10.11.1, though I don’t remember updating my OS since the drive stopped working. It shows up in WD Drive Utilities, and passes the SMART Drive Status check, but fails the Quick Drive and Complete Drive tests. The drive comes up in Disk Utility as well, however it’s greyed out and indicates there’s no space left (there’s definitely a lot of space left on it), and I can’t mount it from there. Every time I try running first aid on the disk it comes up with the following:

“Repairing file system.
Checking Journaled HFS Plus volume.
Checking catalog file.
Checking multi-linked files.
Checking catalog hierarchy.
Checking extended attributes file.
Checking multi-linked directories.
Invalid parent for directory node (id = 7108853)
(It should be 106 instead of 105)
Invalid name for directory node (id = 7108853)
It should be dir_7108853 instead of temp7108853)
Incorrect number of directory hard links
The volume My Passport for Mac could not be verified
File system check exit code is 8.
Updating boot support partitions for the volume as required.
File system verify or repair failed.
Operation failed…”

I’ve tried connecting it to all USB ports on my computer, used another USB cable as well as two USB hubs (one powered), and tried connecting it to numerous other computers to no avail. In the event that it might be a software issue, I’m not sure how to check the drive’s firmware, so I tried using the WD Universal Firmware Updater, but the program doesn’t recognize that there’s a drive plugged in, even if I rescan. Finally I ran the same disk repair operation through Terminal, but this didn’t work either. I’m not sure what to do to resolve the issue that doesn’t involve formatting the drive, which I’d rather not do since I can’t remember if there are important files on it that aren’t backed up anywhere else, being that it’s been a while since I’ve actually used the drive. Any help would be super appreciated – thanks so much!


Based on your experience, I believe your drive is not working properly. I recommend you get this drive replaced; you can verify the drive’s warranty using the link below.

if you need to recover the data from the drive then I recommend using a data recovery software.