My Passport for Mac Time Machine Backup not appearing

I backed up my mac last month to my hard drive and everything was working fine. I tried to access my drive today from a different laptop because my mac isn’t working at the moment but now all the files are missing. I am able to connect and mount the disk but when I open the folder, the hard drive is empty. But when I check the storage info, it shows that there are files inside, they just don’t seem to be appearing. I’ve run the drive tests on the WD Drive Utilities app and it says everything is fine and that the drive passes all the tests.

When I run first aid using the mac disk utility app, I get these messages but don’t understand what it means:

Running First Aid on “My Passport for Mac” (disk4s2)

Repairing file system.
Volume was successfully unmounted.
Performing fsck_apfs -y -x /dev/rdisk4s2
Checking the container superblock.
warning: container has been mounted by APFS version 1677.141.2, which is newer than 1412.141.2
warning: disabling overallocation repairs by default; use -o to override
Checking the space manager.
Checking the space manager free queue trees.
Checking the object map.
Checking volume.
Checking the APFS volume superblock.
The volume My Passport for Mac was formatted by diskmanagementd (1677.50.1) and last modified by apfs_kext (1412.141.2).
Checking the object map.
Checking the snapshot metadata tree.
Checking the snapshot metadata.
Checking snapshot 1 of 1 (
warning: xattr_val: object (oid 0x2): invalid flags (0x6), given name (
warning: inode_val: object (oid 0x15): invalid internal_flags (0x408000 / valid-flags are: 0x3fffdf)
warning: inode_val: object (oid 0x16): invalid internal_flags (0x408000 / valid-flags are: 0x3fffdf)
warning: inode_val: object (oid 0x17): invalid internal_flags (0x408000 / valid-flags are: 0x3fffdf)
Too many warnings of this type generated; suppressing subsequent ones.
Checking the extent ref tree.
Checking the fsroot tree.
warning: xattr_val: object (oid 0x2): invalid flags (0x6), given name (
Verifying allocated space.
The volume /dev/rdisk4s2 appears to be OK.
File system check exit code is 0.
Restoring the original state found as mounted.

Operation successful.

I don’t know how to recover my data, any suggestions?

Time Machine is one of the most important backup solution in macOS systems, which helps the user to take backup of their mac system to external hard drive, airport time capsule and connected server. However, sometime user experienced the time machine backup failure. Here are 4 methods to fix the time machine backup failure issue:

  1. Check the file system of external hard drive
  2. Check the free storage of external hard drive
  3. Uninstall App Cleaner & Uninstaller
  4. Check if other process or services are blocking time machine from running

Further, you can also check the below link for more details in regards to recover data from affected time machine:

Hope this will help!