My Live Book Duo refuses connection: Update


Hi and thank you so long for your help.

Windows 10 Pro 64-Bit on private home network.

Problem started when my NAS was not listed under computers in Windows Explorer. It was listed under Storage. This meant that I could not access any files or folders on my NAS. When I clicked on my NAS where listed under Storage, it open up the UI for my NAS. I have done nothing on my PC or installed other software.
I reset the network and switched on network discovery as a private network. Still it didn’t list. I couldn’t find any solution.
So I formatted the drive. After this it was back to normal as it worked on the day in December 2013 when I bought it. I installed all my software and restored backups and files from my NAS.
This was good until this morning. Same problem. Drive is not listed but I can ping it without a problem. I hooked up my laptop to my home network. It has Windows 10 Home installed. (cable connection & wifi)
Here the NAS is listed under Computer but when trying to access it, I get a network error telling me that the NAS does not want to accept the connection.
Then I tried to connect from my mobile phone with the app. No problem at all. I can connect, see everything and access it. Same goes for connecting from the web. No problems at all.

When going to the UI on web page, I checked the following: When I click on the NAS where it is listed under “Storage” it opens up the UI.
While I was there, I checked again all settings and username. There I am listed as “Deon”. But, when I formatted my PC, I opted to sign in with my Microsoft account, where I am “Deon Surname”. When I wanted to change my name from “Deon” to “Deon Surname”, the UI did not want to accept the space between my name & surname.

I will REALLY appreciate any help to solve this. I really need to use my NAS as I bought it to do daily backups as well as when any file changes.

Thank you so long.

I have just connected my NAS directly to my PC, no router, no switch; PC directly to NAS with cable.

  1. It picked up my NAS under “Computers” together my my own PC.
  2. When I click on it, I get Win Pop-Up: “We cannot access \MYNAS”.
  3. I click on “Diagnose” button.
  4. “The remote device or resource won’t accept the connection Detected”
  5. I click on “View detailed information”.
  6. "The device or resource is not set up to accept connections on port “The File and printer sharing (SMB)”.

What bugs me is that I have changed NO settings on my NAS for the past 4 years, why now all of a sudden?!

I will really appreciate your help. I am stuck and urgently need access to my NAS.

1 Like

I am having the exact same problem. Have you had any luck in solving this please?

Hey Same issue for a couple of days , sometimes it would work after rebooting my dhcp server along with the NAS. Today I decided no, I’m not going to do this every time the power goes off (Live in RSA, so every 2nd day). Turns out my domain names were different (NAS) HOME vs (DHCP server) Home,
If i’m not mistaken WIN 10 doesn’t use domain names anymore , however the NAS still relies on it (stand to be corrected)
Anyways I can’t say for sure that this was the problem, only that this resolved it for me.