My Cloud OS 5 won't save from iOS phone

As the title says, trying to save files form my iPhone to my MyCloud Ultra (updated to OS 5), nothing happens. I can “share” to the destination, which is bit of a workaround, but if I have to save multiple files, I have to navigate my directory structure each time rather than it remembering, which can be quite cumbersome

I’ve seen someone else with this problem resolved it by disconnecting the My Cloud from the power and then restarting it, however that hasn’t worked for me.

Has anyone else had this, and if so, how did you resolve it other than the power-off method (if at all)?

There are multiple ways to store files from an iOS device to the MyCloud Device.

  • MyCloud OS5 App
  • Native Files App (You need to enable MyCloud on the sidebar inside the app first)
  • ‘Sharing’ via the iOS Share button
    – selecting the MyCloud OS5 App
    or — selecting the Finder app (for me it remember the previous location)
  • Connecting to your NAS via the SMB protocol inside Files app (to address similar to smb://mycloud.local)
    or – any other file management app ape to connect to SMB, AFP, NFS, FTP

Hope this helps.

Thank you, but I know all of those options; it’s specifically the “native files app” approach that stopped working after I upgraded from OS 3 to OS 5. I can do the “share” route (as I described), but that’s clunkier than it should be, and I can’t use the SMB option as I use the system remotely.

My Cloud is already listed on the Files App sidebar, however when I clicked through it said I needed to authorise My Cloud. I seem to have achieved that (not entirely sure how), but it’s still not saving - it prompts for the location, but doesn’t actually save the file :frowning:

As far as I can tell, everything is set up correctly, but that one (very important) feature doesn’t work (it did under OS 3).

  • I would log out and log into MyCloud from NAS Dashboad
  • and uninstall and re-install the MyCloud App
  • Also set up the Share permissions for Cloud again.