My cloud mirror problems

I just switch from wd my cloud to my cloud mirror, since i needs to use third party apps like phpmyadmin and small php scripts.

I installed phpmyadmin easy and runs fine

then i tried to install wordpress, and don’t works

Fatal error : Allowed memory size of 8388608 bytes exhausted (tried to allocate 1920 bytes) in  /mnt/HD/HD_a2/Nas_Prog/WordPress/WordPress/wp-admin/includes/media.php  on line  492

 

(this is a comun wordpress error, but need to edit configuration file to try to fix)

 

 

Also i put ssh access ON, put password and i cant login via ssh – ANY IDEA what can be the ssh problem?

 

 

SSH problem was the username its SSHD not root

I think you got an EX2, not a Mirror…

I have my cloud Mirror, i bought this today. 

There is APPs installation option

PHPmyAdmin -> Works

Wordpress -> don’t works  (Allowed memory size of 8388608 bytes exhausted)

Joomla -> don’t works  (After create database, user when you add information, keeps loading forever)

THere is a user sshd (you can set password) but no option to log was root

i dont know what they did, but i cant use another php script, like my own code

i will try this for 10 days, if not works, i just go back on best buy and get a full refund, and i will never buy WD cloud whatever anymore, after 1 my book live (crazy work) 1 my cloud live (after firmware update, stop working) i m try my cloud mirror.

Yup … I stand corrected!

BTW, sshd user maps to root.

Yes, but for me nothing works correctly.

he store the apps on /mnt/HD/HD_a2/Nas_Prog like wordpress, phpmyadmin etc.

I have alot of small scripts, i want to have all stored on mycloud before i publish on my dedicated server. Actually i have this on my pc using xampp, but i m try to put all on the wdcloud to get acess from my phone, tablets etc if i need.

I will try do something without make crazy changes on debian, if not works, i will return get my refund and try BUFALLO Link Station

Add

‘’’’ FTP access dont works, i really dont understand why they offer features if not works.

alvarogtc - Thanks for your post…now I learnt that the mirror also supports apps like my EX2.

As for ftp access, how exactly is it not working for you? Are you trying to access via ftp from outside the network or from inside the network where the mirror is located? Knowing these details could be helpful in perhaps giving suggestions for some workarounds/solutions.

BTW, I’d warn you at the outset…this product was launched just a couple weeks ago. It’s a very new product and unfortunately that means there will be inevitable kinks that would need to be worked out by WD…and given how frustrated you’ve been with previous WD products, I’d like you to lower your expectations because I’m sure you’ll find a few more stumbling roadblocks that comes with buying a brand new product. If you bought it another 6 months later, you might’ve had a little more smoother experience than the bumpy ride you are in for with a brand new product. So it’s good that you have made up your mind to give it 10 days and if the issues are insurmountable, then you’re prepared to return it and buy a Buffalo NAS (or another NAS). Always helps to make alternate plans.

The FTP i m try on same network.

I can log using ssh connection (sshd user)  there is no option to log was root and sshd dont have full privilegies. 

I understand its a new product, but how many tests they did before release? hundreds? 

I have a dedicated server with centos, i upgrade myself, i install libs etc easy.

My cloud mirror i cant understand the file strucutre they used.

Usually websites r stored on var/www/ or var/www/httdocs or /home - they put a link on var/www and php scripts are on another partition. /mnt/HDD …

I tried install wordpress almost 10 times, same error, joomla 5 times or more same error.

Snap 2014-04-26 at 12.32.41.png

Snap 2014-04-26 at 12.33.26.png

for have something for not work like i need i have alot of options more cheap.

Mycloud Mirror + Tax + Best Buy warranty (replace) - $ 450,00 so i can use buffalo cost 200,00 or less.

Actually sshd is the root user…id command will reveal that…it should have all the privs of root.

The website, at least for the dashboard IS at /var/www…I don’t know about WordPress, etc.

But you aren’t alone…apparently My Cloud EX2 is having the same issues -> http://community.wd.com/t5/WD-My-Cloud-EX2/Wordpress-Fatal-error/td-p/727096

After couple days of errors, bugs and more erros, i returned my cloud mirror, got a full refund. then i buy a netgear readynas 100, 2 WD RED 2 tb and works perfect, also there is about 50 apps available. Full root access, total factory restore iven if you make linux crazy.