My Cloud gen 2 4TB ? bricked with solid blue LED

Hi. I have a failed OS5 update on My Cloud gen 2 4TB with a difference. After looking at a flashing blue LED most of last week I’ve now got a solid blue LED, but I’m still unable to access it.
Windows 10 correctly reports the device, MAC address and URL (, changed since update). I can ping it. nmap port scanner output copied below. But browsing to it or ssh (putty) just hang forever, with no output or error.
I have tried a few checklists of things like enabling SMB 1.0, netbios over tcp, disabling firewall, network discovery, a registry edit, resetting the network, 4 second resets, 40 second resets. Something has given me the solid blue LED but not access.
I don’t care about saving the NAS but there is some data (esp. photos) I don’t have any other copies of. So I don’t want a solution that re-partitions/wipes the drive. I know I may lose it anyway. Lesson learned about redundancy.
And I just gave away my old tower PC with linux which I could have plugged it into. Now I have only laptops in the house.

Any suggestion on next steps?

Many thanks

22/tcp open ssh
80/tcp open http
111/tcp open rpcbind
139/tcp open netbios-ssn
445/tcp open microsoft-ds
548/tcp open afp
2049/tcp open nfs
5357/tcp open wsdapi
8001/tcp open vcom-tunnel
8002/tcp open teradataordbms
49154/tcp open unknown

A “last resort” option is to remove the hard drive from the My Cloud enclosure. Then using a powered USB to SATA adapter or USB to SATA docking station/adapter, connect the hard drive to your laptop. Then, if using Windows, one can use third party Linux drivers like any of the following to read the EXT4 data partition of the My Cloud hard drive and copy off any files:

Or one can create a Linux Boot Disc/Boot USB Flash Drive to boot their Windows laptop with to read a My Cloud hard drive attached to their laptop. For example:

Unfortunately some are having their single bay 2nd gen My Cloud units hang and become unresponsive after updating to OS5 firmware. Seems to be due to the “indexing” OS5 firmware does. If one is eventually able to access the My Cloud Dashboard (by name or by IP address) then try disabling Cloud Access and other features like Twonky if installed/enabled.

1 Like

Thanks. Was not aware of the USB to SATA adapter. I’ll figure it out from there.

If you do go with a USB to SATA adapter, just make sure it supports 3.5 inch desktop style hard drives. This likely means a powered USB to SATA adapter.

1 Like

if you have a broken common WD MYbook data unit that unit has a SATA to USB adapter inside and a included external power supply.

If you are careful you might be able to open a working my book and put it back together good as new - I was in a hurry.

Now it is almost good as new thanks to Adam Savage approved duct tape :slight_smile:

Thanks but no I don’t. However I should have thought of re-using the drive which seems fine on the adapter as suggested by Bennor. I’ve just ordered a lower end 2 bay Synology with 2 drives and I probably could have saved my money one one of the drives. I won’t be staying in the My Cloud ecosystem after this experience.

This happened to me after upgrading. I could still login to the admin dashboard but no other access. This is the only solution that worked for me, and now a few days in with no issues. I’m not sure what registry edit you tried, but this one worked a charm on my MyCloud Ultra EX2. Hope it works for you as well. I use Windows 10, remember to login with an admin account, in my panic I kept forgetting this…