My Cloud dead, how to see content on Windows 10?

Is what content encrypted? The /DataVolume/shares folder on partition 4 of the ext4 formatted HDD in the MyCloud?

No, it’s not encrypted. It’s simply a different file system that isn’t natively supported by Windows.

The MyCloud is a Linux computer that acts as a file server. So it uses a Linux file system. It is not simply an external hard disk drive.

The user data partition on the My Cloud is not encrypted. As far as I have seen when unbricking a My Cloud, none of the partitions of the My Cloud are encrypted.

When one mounts the My Cloud hard drive in a separate computer they will see several partitions. In the case of the v4.x firmware My Cloud’s the user data is located on partition #4 (for example in Linux: sdb4) which is formatted for EXT4.

So, I’ve read through both your post, and I can’t thank you guys enough! ^^

Just to be clear, I want to explain step-by-step how I’m going to do this, and I just want a confirmation, from one of you guys.

  1. First and foremost I have a Surface pro 3 that I’ll be using.
  2. I’m going to buy that hard drive enclosure because I think it’s neatest (both power and USB-port)
  3. I’m going to put the hard drive inside it, but before doing that I will download ExtFS for Windows by Paragon.
  4. When installed I’m going to start up the thing (hard drive cabinet) and also open up the program.
  5. By the things you guys said, I will be able to see the content on the hard drive the way I used to (like folders and stuff) and nothing will be encrypted (?).
  6. Moving the content to another safe hard drive and I will toss the ■■■■ thing (My Cloud) hundred miles away.

Am I on the right track? (Sorry if I’m a bit of a noob on all of this, but It’s the first time^^)

You may wish to save the data from the drive onto another disk (borrowed?), and then format to NTFS, and just have it as a normal Windows-compatible USB HDD. Note that the trial version of Paragon ExtFS only has a 10-day trial period, after which it degrades the data transfer rate.

I haven’t used ExtFS, so I don’t know how well it integrates into Windows; i.e. does it work like a device driver, allowing the disk to appear transparently as Windows disk, or whether it needs ExtFS to run as an application. My original suggestion of Paragon was based on the concept of temporary use for data recovery, not regular use under Windows.

Or sell it on eBay. With a note saying it’s not working, of course. I’ve been thinking of looking out for MyCloud enclosures on eBay, with a view to making a ‘just to play with’ box. One with a broken network port, I’d hope to be able to get working again (possibly rather optimistically…).

The other possibility is to recover the data, and then try to resurrect the device using one of the ‘unbricking’ procedures to restore the operating system and file system; it may not be a hardware fault.

http://www.linuxinsider.com/story/78760.html
when reading this article, it seems that you can actually see the files, or am I lost?

Not sure what your asking. From Paragon’s website: https://www.paragon-software.com/home/extfs-windows/

Paragon ExtFS for Windows®
Fast and easy read/write access to Ext2 / Ext3 / Ext4 under Windows
Free trial with unlimited read and write operations*The latest Ext4 features support
Read/Write support for LVM (Logical Volume Management)
Supports Windows 10

Can you “see” the files? Yes once the Paragon program is installed one will be able to read (or see) and write files/data to the My Cloud hard drive that is attached to a Windows computer.

That article appears to answer my question: it seems that ExtFS allows you to mount a Linux file system partition as a named drive letter, which can then be used just like any other local or network drive, by any Windows program.

That’s what I wasn’t sure of: I was sure that it would let you access the data on the drive, but I didn’t know if it would only allow access via a Paragon GUI (rather like the WD Desktop app allows access to the MyCloud), or whether it would allow ‘mapped drives’, available for use by all Windows programs.

I just really really really want to thank both you @cpt_paranoia and @Bennor!! :smiley:

I succeed! I did like I told you I would and everything worked fine! I found all my files and I’m now transferering them to another external hard drive!!

I give you guys long cyber hugs! You just saved my life!

Thank you!

1 Like

Glad to see you were able to get your data off the drive. :smiley:

Obviously there is a lesson to be learned here. If your data is irreplaceable or mission critical then have multiple avenues of backup and data recovery.

Once the data has been recovered from the drive you could try one of the unbricking procedures (like the one linked to earlier in thread) to see if you can rebuild the My Cloud drive so it can be used again within the My Cloud enclosure…

Nice to hear that. In future I recommend to offer a disk for a safepoint. Data in this are saved as NTFT data on windows and data can easily be transferred

this thread saved my life, thank you !

You guys are amazing. I thought it was lost forever!

thank you so much my friends!! extremely useful and deserving to be on top of rank

Thank you so much! This saved my marriage!! :slight_smile:
ExtFS didn’t work for me, I tried DiskInternals Linux Reader…

@cpt_paranoia & @Bennor
Dear friends, I am having the same issue

My home cloud suddenly dead and went offline. I connected with Paragonm, I found the disk with 1.2TB data, however, I cant find the folder structure I used to save my files in home cloud

this is the disk I mounted

But it show like this

Is there any way I can copy my files out of this WD POS with my folder structure?

Million Thanks!!

PS: I am using my cloud home (single hard disk) 8TB, I read some more post last night and I cant find any inbrick post for this model, so I worry if I use the my cloud 4tb image to unbrink will cause issue

Is it unbrick is the only way to get my files back in the original folder structure?

I don’t know the file structure on the home device. But your file should be under the mnt directory. On the gen2 My Cloud the data is stored in /mnt/HD/HD_a2/Public

thanks @rac8006
checked, dont have this folder in my cloud home
and I checked the size, it show something like this
I think somehow I must use the cloud home to read my file, but I think it is brick in last update, the light is always on White, but I can ping the IP in network, just said offline in WD discovery
feeling super sad as I bought this for me 1 year son and now… :frowning:

https://www.dropbox.com/s/u3ctwn897dnfv74/2019-06-09%2021%2026%2043.jpg?dl=0

Try posting on the My Cloud home section.

thanks! Ijust found out that there is a “My cloud home section”
I was search those posts from Google