My Cloud 3TB "No Internet Access" message but everything is working

Hello there everyone,

I’m having an odd problem where everything seems to be working fine, I can access my files locally at amazing speeds and I can also access my data remotely over the internet using my 4G connection with my phone etc., however when I go to the WD My Cloud’s Dashboard, then go to Settings under the General sub menu the “Cloud Access” indicator sometimes shows as “Connected - Port forwarding connection established”, while other times it shows as “No internet access”.

I have rebooted everything countless times, I have ensured that port forwarding on my Netgear R6300 Router is setup correctly where port 80 and port 443 are correctly forwarded to my WD My Cloud’s IP address on my network, I have also configured static ip address on both my Netgear router and the WD My Cloud device itself under the Networking settings on the Dashboard.

I can however connect perfectly fine to everything both locally and remotely which I find amusing :slight_smile: the only problem I see is that the My Cloud is unable to check for new firmware for example which is disappointing, I’m also not sure if my connection to the device is actually being established directly or relayed through the WD servers when I connect to it remotely (which I know is not the best optimal situation in terms of speed access for transfers/uploads etc. ).

Any ideas on how to correct this? WD has been of no help at all so far, sent an e-mail yesterday and no response so far, I tried calling them this morning and I was literally on hold 7, 30 and 25 minutes respectively to just be hanged up at the end, one rep said he didn’t know how to solve networking issues and just put me on hold then I found myself back on the first menu where you have to start all over again, horrible customer service.

Any help would be greatly appreciated!

Hi have you tried doing a system restore?

Page 84

I am having the same issue.

Is it really necessary to do a factory restore?  Mine is brand new out of the box and on the correct firmware.

A factory restore on a 3 TB drive will take forever.  Is the issue not in the system software?

The error message I am getting is:

No Internet access. Check your network and try again. (220004)



It’s seems that NTP Service is working as it updated my time to the correct. 


It must be an error displaying on the page.  As it is connected to the internet as I can access the drive via iphone app on 4G LTE outside of the home.

However the firmware update page still displays the  - No Internet access. Check your network and try again. (220004) - message when trying to check for new software.

So there is still issues, I am going to guess it is a software/firmware issue.

Yeah, I gave up lol, def a cosmetic bug, I did a full system restore and it looked like it was fine for a while, but now it’s back to the  - No Internet access. Check your network and try again. (220004) - message, Finally WD reached to me yesterday via e-mail and a rep. also called, but then again, I told them it was fine (because it was at the moment) I guess I’m gonna just wait for their next firmware update, def a bug that no rep. will be able to fix as it’s on the software itself, let’s hope WD releases one that resolves this once and for all and hopefully soon because I won’t keep it passed my return grace period, otherwise I’ll return and just wait till they iron out all the bugs within a few more FW/SW release circles.


There’s no “cosmetic bug,” really, because mine reports normal.

My guess is that it’s failing a connectivity check and telling you that it can’t reach the internet.

I’m scanning through scripts to see what it’s testing, but no luck so far.

Are you sure you’re not blocking anything in your router, or blocking via DNS settings (OpenDNS, etc) or whatever?

TonyPh12345 you are the man!!  that is what the problem actually was, I use OpenDNS for parental controls on my router, as soon as I removed the OpenDNS dns servers settings from the router the MyCloud started reporting normal conectivity immediately! thanks so much for your help, now what I wonder is what address is it that I need to unblock or whitelist from the OpenDNS parental control settings to make it work, because I really need parental controls.

Thanks so much for your help once again, you nailed it!

PS: Added and as exceptions on the parental controls and now it all seems to be working fine, crossing fingers!

Heheh… Excellent.    

I fell into the same trap when I was beta testing the old Slingbox Solo a while back.    Those software guys were all over the place trying to figure out what was messed up, they got their network guy on the phone, he was watching their systems while my Sling was trying to register and said “I’m not even seeing your IP address show up – ever.   You aren’t using OpenDNS are you?”  :)

In that case, it was classed as “Online / Web Video” or something.  

The easiest way to do it is to shut EVERYTHING off on your network.

Reboot the Cloud a dozen times or so, and then go look at the Blocked Domains list on the control panel for OpenDNS.

If you can figure it out, other folks would probably be helped if they search for the same issue.

Thanks again TonyPh12345, it never passed my mind that it could have something to do with the DNS lol, I added and to the parental controls as white listed and now it still shows as “Connected” eventhough parental control is still enabled, weird part is that I never had a problem accessing those websites on the browser though, hmmm wonder what else OpenDNS blocks that I don’t know. still waiting a bit sometimes DNS changes take sometime to propagate, but if I have problems with this again I now know where to look, thanks it really had me puzzled!