My Cloud 3TB "No Internet Access" message but everything is working #2

Dear Mates, Hello everyone.

Pls. assist to me in following, before my question I’ve read these topics, but it did not help me.

http://community.wd.com/t5/WD-My-Cloud/My-Cloud-3TB-quot-No-Internet-Access-quot-message-but-everything/td-p/647519

http://community.wd.com/t5/WD-My-Cloud/Firmware-EXCLAMATION-POINT-v03-03-02-165/m-p/714040/highlight/true#M12159

As above , in my case everything is working, except the status of network and checking update. Pls. see attached screen.

The “My cloud” is connected to ASUS RT-AC66U without any special settings, just setup of network provider.

Could you pls. help me?    To be honest it is not so big trouble, because all main functions are working, but it is logical that I wanna to make all functions worked.

Thank you in advance.

It is possible you need to configure the WD My Cloud for a static IP address and ensure you have the IP address in the same subnet as the router/gateway’s IP subnet, ensure the “Gateway” IP address is the address of local network’s gateway or router (main router on the local network if using more than one router), and finally ensure that there is at least one "DNS Server entry for the three DNS server fields. You can set the static IP by accessing the WD My Cloud administration screen then select “Settings -> Network -> Details” (found under Network Services).

In the past I had one device (not a WD My Cloud) on my local network fail to gain internet access until I manually set the Gateway and DNS server fields. I had to use  public DNS sever addresses and not the DNS server addresses my broadband provider uses or provides.

If the WD My CLoud is still unable to access the Internet then check your router or network firewall to ensure its not blocking outbound access for the WD My Cloud.

Thanks! I had exactly the same problem as topic starter describer. “ensure the “Gateway” IP address is the address of local network’s gateway or router” worked for me. I noticed that MyCloud had forgotten (probably) Gateway IP. Adding that resolved the problem.

I’m most glad you have been able to resolve this issue.