My book not showing up?

i have a my book that wsa giving me problems (i/o error and periodically telling me i had to format it to be able to use it).  I bought a replacement external HD, but before I could transfer the data over, the WD stopped working completely.  Now I can finally see it in the USB viewer and device manager, but it still does not show up on My Computer.

I don’t mind reformatting the drive if i have to, but i need to get a bunch of files off of it before i do and the drive doesn’t show up in any of the data recovery programs i downloaded.

can someone please help?

Does it showup in Disk Management? If so then maybe TestDisk will fix the corrupt partition data.


test disk only shows my c drive.  now i’m even more confused.

edited to add that yes it does show up in disk management

Try disnonnecting the drive and shutting down PC then unplug the power to PC for a few min and reboot. This may restore some setting that got messed up that simply powering down won’t.


well i tried that and still no luck.  test disk still doesn’t see it at all.

when i click on the WD drive on disk management, it shows as not initialized.

also, the WD data lifeguard shows it as a physical drive, capacity 0 and smart status not available.  it isn’t listed in the logical drive section.

one of the recovery programs i downloaded did see the drive and said that it is fat12.  what does that mean?

Try what I did.  Install Ubuntu onto your computer or run it from a disc.  Its a linux OS that runs like an application within windows so it doesnt replace anything.  Once I had Ubuntu running I plugged in the EX-HD and it opened it up.  The drive was still toast but it was enough so I could transfer over all my data to new one and then reformat the broken one.  When in Ubuntu if you goto system settings you can then select devices and see you drive plugged in and it will let you know what the problem with it is specifically.

well i tried to install ubuntu and i got as far as veryfiying the install but it came up with an error saying that no root file system is defined with an option to click ok, but it keeps popping up.  (i did a little google searching and i read that it is a known bug with wubi.  i am not sure what wubi is, but i do know that on the disc i burned, it said somehting about installing with wubi)even so, i was able to click on system settings and i saw the WD drive and it said the same as it did in Windows;  capacity 0.  it did say that it was not partitioned.

i am at a total loss as to what to do now.  this drive has pictures, music, videos of my god daughter, ebooks, my clients website files…  i am pulling my hair out!

some of the things i have read say that i can try connecting it directly to the motherboard, but i am deahtly afraid of doing that.  the last time i opened the case of a computer (to put in some extra memory), i fried the computer.  i don’t know what i did, but all it would do when you powered it on was beep.  it is bad enough with the potential loss of the external drive, i can’t afford to fry my computer.

i have downloaded various data recovery and partition repair programs and i am going to try them one by one and continue googling until i get to the bottom of it.  hopefully “the bottom” will be saving my data and not reformatting.

does anyone have any other advice?  i’m desperate!

just a little more background info in case it helps someone work this out:

the hard drive was giving me issues (as i mentioned above), but the problems started in earnest when i upgraded from xp to windows 7. 

as i mentioned, i bought a new external hard drive to back my files up to.  i shut my computer down, plugged the new drive in and turned the pc back on.  previously, the problematic drive was drive G.  however, the new drive booted up faster than the old one (especially given the issues it was having), and got assigned as drive G.  that was the point at which the old drive stopped being recognized at all.

You most likely fried your computer in the past because you didn’t touch a grounded piece of metal first and ent a static shock into the motherboard.  As for wubi/Ubuntu.  Don’t run it off the disc.  Disconnect your EX-HD then save wubi to your desktop.  Install it to your hd and allocate atleast 10gb for it.  afterwards restart your computer and keep pressing F8, F10 or F12.  One of those will bring you into a boot menu and one option will be Ubuntu.  Run that and then plug in your problamatic HD.  If it doesn’t pop up then goto your settings (within the ubuntu program) and select hardware and then it should recognize it.  Finally start transfering the data onto a new HD.  Afterwards you can then reformatt the defective HD and hopefully it will work again.  Thats how I fixed my problem.

First, thanks for the laughs. Your “tearing my hair out” certainly rang a bell with me.

Second, did it work? I am experiencing the same, or at least a very similar, problem. And, like you, I have pictures, something over 300 albums carefully saved from vinyl, and my books.

Thanks, in advance, for the help.



This is an old thread start a new one explaining the problem give your OS and what you have tried so far.


I had a WD My Book Essential 2TB external drive that started slowing down. I tried updating the WDSmartware, then removing the WDSmartware, but it continued to show signs of failure. The drive finally stopped responding, and would not be recognized by WinXP. The former blue bars on the “spine” of the plastic enclosure no longer lit, and only a single LED would flash when it was plugged in to the USB port.

I tried file recovery and partition recovery software, but it only showed garbled, unorganized and renamed files. I didn’t want to lose the data that was on the drive. By this time, the drive had stopped responding at all, and any time I plugged in the USB my computer would freeze. It would not boot with the drive plugged in.

After a call to WD tech support, they suggested I try using a computer with a newer version of windows - either Vista or Win7. That finally jogged my brain to try Linux. That did the trick. I booted my PC with Knoppix Live, a distribution of Linux that runs from a CD. Linux mounted the WD MyBook with no trouble, and the file structure was intact! I transferred all the files to a new internal HD I had installed for that purpose, and all my data was saved. Rather than reformat the drive, I RMA’d it back for a replacement. I feel that this is a problem with WinXP, but don’t have the technical expertise (or time) to run it to ground. The slowness of the drive may be a software problem, but it also might have been a hardware failure, so I opted to replace the drive rather than try to revive it.

Long story short - if your drive causes WinXP to freeze, or WinXP doesn’t recognize the drive, try booting with a live Linux CD and see if you can reach your data that way.


Thanks for sharing. I’ve suggested the Linux Live CD before but nobody ever replied back with their results.