My book I can't see it on my PC

                                    I can’t see my external on my PC, but  it’s   detected by a PC  even if I open my computer I can’t see it. what happen?  someone can advise me what to do?  thx

More information will help. What OS? What Drive? Does it show in device manager? Does it show in disk management.


This may help:

Find the SmartWare folder (in my computer it’s under the C drive)

In the folder is an “Unlock” icon.  This controls access to My Book.

Enter the password if you have one.  I do not know what instructions come up if it’s not password protected.



     my OS is WIN 7 and my drive is WD my book essential WD 10000H1U-00.  so it show in divice manager but in the Disk management it say the Disk is not initialised ( not show it)

Did you try to inatialize it? if not try that. It may need a drive letter assinged too.




              there no  way to initialise it because u can’t see it, on the disk management it say the disk unknown is not initialise. only u see it on the divice manager

I’m chiming in here with a similar problem.

My trusty My Book 250 MB has worked perfectly from plug in +3 yrs ago until today. 

I noticed it was strangely quiet, then saw it wasn’t listed on My Computer directory.  It still has it’s glowing green circle but is otherwise lifeless.

XP Pro SP3, using USB 2 port. 

All connections are solid.

I don’t see it in the Device Manager, at least that I recognize.  There are five functional USB controllers, some IDE ATA controllers but I think that is for the hardwired drive. 

I ran the WinDlg.exe diagnostics but it doesn’t see the My Book. 

Since it’s been so trouble-free I don’t have the moves down for troubleshooting. 

It hasn’t made any unusual noises and was involved in my automated backup last night. 

I think it  predates the SmartWare software.  I don’t find it installed and it can without a disk. 

What are the troubleshooting steps?

If it is dead is there any way to grab the contents?  It was my backup.



Got it back!  Seems it was a flaky USB port.

I found instructions on the WD site that may be of use.  The link won’t paste in, so go to and search for

"A WD external drive is no longer given a Drive Letter by Windows (XP, Vista, ot 7), and data on the drive is inaccessible.

Good luck!