My Book Live - Files no longer visible (MyBookLive 02.43.03-022 : Core F/W)


I bought a My Book Live 3TB drive a mouth or so ago. I copied all my movies and series on. I also bought a WD Live TV to access the movies on. It was all working 100%. Then i decided to copy my music onto the MBL. Once i had finished with that i could no longer see any of the files on the WDLTV.

I logged into the GUI interface via my browser and i can see that the files are there as my drive has 612mb used. Previously if i moved my mouse to the bottom of the screen where the bar is it would show me in different colours what is taking up the space for eg .music .videos etc. Now the bar at the bottom stays grey.

So the files seem to be on the drive but i cant seem to access them via any means.

Anybody have any suggestions?

Content scan probably hasn’t finished.

Access your MBL from your WDTV via network shares instead of Media Server…  you’ll probably be more satisfied.


Thank you for your reply.

I tried that but i still cannot see any files. Basically it is telling me that i have 612 meg used on the drive however i cannot see any of these files. I have tried on the WDLTV and tried via my mac and via the WD cloud software and via the GUI.

Nothing. Its like the files are not there…