My Book says it is empty when accessed through TV

I used to be able to access my book through my TV and my home cinema system but not any more. It can be seen as a device on the network along with my PC. When I select (MyBookLive) TwonkyMedia it enters but says it is empty.
I have been through every setting I can find on the dash but it will not show the content. When I select my pc I can access all the shared files.
I can access my book from my iPad and phone and pc via the home network.

The tv is hard wired to the network.

Any advice?

Hello,

Does resetting the MBL makes any changes?

Have you tried disabling the media server and enabling that again?

I recently solved a similar problem with seeing a drive from my WDTV media player and from Kodi on a Fire stick, even though drive was seen, no files showed up. Although the drive was shared to the network and my other PC could see it and access its files, nothing else could.

It occurred to me that because the drive was plugged into a USB 3 hub connected to the host PC, it actually should be plugged directly into the PC USB 3. I did that, and all the problems disappeared! So, always plug a shared drive into the host PC, and not its hub. Hubs are not always direct replacements for the ports on a PC.

Thanks for the replies.

I have reset the MBL and it is up to date with the latest firmware.
I have run through the diagnostic tests and all is fine.
I can access the files through the internet any where and using the cloud App.
I have reset the network hub and checked the settings.
I have two Samsung TV’s, both on the network and both can see MBL. They can both access the drive but the message is the same that there is no content.
It is not connected to my pc, it is connected to my network via an Ethernet cable. If it was connected to my pc then the pc would have to be on all the time.

Sorry, I did not notice that you have the “Live” that connects to the network. So, in that case if it is on the network, what kind of files are you looking for, and are the files on the drive in the format your TV is able to play? , e.g. mp3, mp4 or jpg?

The files are all MP3, jpeg, MP4, avi, etc. They are all in folders and both tv’s and the cinema system used to be able to see them and play them.
This has only happened over th last few months.
I have Infinity with the latest hub. That is the only thing that has changed but I am pretty sure it has worked with that.
Thanks

I have no other suggestions, so contact WD Support.

I have exact the same problem! This happened after the setup of my new modem/router, a Compal Connect Box. My Book Live is (1) not able to connect to the internet anymore and (2) the Twonky server is useless, though it is visible on my smart tv. Twonky says it’s empty.I tried to forward some extra ports to the router, but to no avail. I feel that the new modem/router is somehow blocking the content of the MBL, because before this change in the network everything worked like a charm. I used the option to activate UPnP and was disappointed to see that DLNA did not work. I tried to find solutions on the internet without any success, so if you, Laika, found out how to handle this and could tell me, I would be much obliged!

Thanks Bud.
It is damned annoying. Used to be able to view my pictures on the TV or stream a movie but now just says empty.
It may be my new modem but it was the same as the last one. The latest one from BT and all was fine before. The only other change was I updated the firmware on MBL.

A way out for me might be to set my modem/router to bridge mode. In that way I will lose the router part in my Connect Box (so then it is modem only, just passing on the internet) and I can use my old Gigabit router for my network again.
As for now I am still hesitative to do so, because the router in the Connect Box is pretty good for the wifi and I am not 100% sure if bridge mode is the solution for my problems. Furthermore I cannot do this change in the setup by myself, but must ask my provider and after that I will have to change IP-addresses again. Annoying indeed!

But maybe all of that is much easier in your situation! So give it a try and let me know the results of your efforts. Good luck!

I recently found my way out! This might be the answer for you as well.

  • Use your dashboard to enter your My Book Live.
  • Go to settings - Media (top right hand corner of this page).
  • You’ll see ‘Twonky service’ (must be enabled of course).
  • Right below this you see ‘Status’. Unfold this item and check if your database is filled with different sorts of files.
  • If not (in my case it was empty): select ‘rebuild’.
  • After a couple of minutes Twonky will have indexed all your files and can show them on your tv again!

It is quite well possible that My Book uses slightly different terms, because I had to translate them from Dutch into English. Sorry for that.

Thanks for this. Been away so I’ll give it a go and see what happens.

Success.
Spot on.
Thanks

1 Like

Everybody happy? Yeah!