My Book Duo drives won't mount?

I have two of these My Book Duo drives connected to my Mac Mini, running OSX 10.9.

The drives are both configured as RAID 1, one has my iTunes and other media, the second one is the Time Machine backup disk. Last night when I restarted my computer neither drive mounted. I got an OSX error “THe disk is not readable” and a WD error “RAID stripe set has failed” box.

When I open the WD drive utilities I can’t run any of the Diagnostics and the RAID Management tab says “RAID Status: Unknown” and suggests that I re-configure the drives.

I don’t want to do that, obviously, as there is a total of over 3TB of data on both drives! It’s suspicious that BOTH drives failed to mount at the same time… sounds like some software problem perhaps?

I have updated the firmware on both drives and power-cycled them, restarted the computer several times, the usual things, but no luck.  On a whim I tried updating the firmware a second time and got a different error in the firmware updater: “The drive is locked.”

Any thoughts on what I could try?  I’ve opened a Support Case with WD but oftentimes other users can be even more helpful!  ;-)

Thanks, David

Hi there, have you tried to test using the drives on a differen computer? This can help you narrow down the issue, you can also try to use a different USB port.

Hope this can help you out.

Thank you, but I don’t have another computer readily available.  I have tried switching around the USB ports but no effect.

I suspect that there is a common cause, since I have two of these drives connected and they BOTH failed to mount AT THE SAME TIME (following a restart).  

That’s probably a clue, but I don’t know to what…