"RAID Stripe set has failed" message on Mac yosemite ... help pls

Just got a My Book Duo (12TB) some days ago and got the captioned error message. 

While Aperture was relocating some 17,000 iphone pictures (about 50GB) to this ext hdd in the mid night.  When I woke up in the morning, I got this error message " Raid Stripe set has failed", while the picture allocation has completed without any error message from Aperture.

No error was found using WD utility - SMART Test ok, Quick Test ok and RAID status is normal and online.

Does anyone have similar experience?  Any ideas about the cause of this error message?  Should I return my 3-day-old duo to the shop in exchange for a new one? 

Many thanks in advance for any sharing. 

Further background 

  • Am running a Duo on Raid 1 (mirror) with an iMac (late 2013 version). 

  • O/S Yosemite

  • Duo firmware: 1.026 (latest)

Hello ngkhhk, welcome to the WD Community. Difficult to know why you got that error message. You can try running a full scan to be sure nothing is wrong with the My Book, note that this will take several hours to complete. You can also try to contact tech support directly for assistance on this. 


1 Like

thanks jubei for the sharing.

it was stuck at the complete drive test.  i contacted the local reseller and they offered to exchange me a new one.    

Im gettting the same error message. My drive is a couple months old. Ive done the full scan each time after I get the message an it says my drive is fine. ??  confused.

Has anyone come up with a solution for this? I have had my my book duo 12 TB for a few weeks and it is doing the same thing.

Help please.

I’m having the exact same issue with my 2011 iMac running Yosemeite 10.10.2.  I have a My Book Duo 8TB set to  RAID 1.  I’ve only had the drive array for about 3 weeks.  When I first encountered the message I contacted the WD Support.  They basically said either one of the drives is going bad, or the RAID array volume created the first time is corupt.  Now all the WD Utility diagnostics show my Duo as healthy.  So I wiped it, loaded the most recent firmware given to me by the support tech (which was the same firmware on my Duo to start with, since it’s brand new and the newest firmware is from Oct '14) and configured it again.  Came down this morning to the same RAID Stripe Failed error message for now the 4th time total over 3 weeks.

I can’t think of anything else to do than to take this back to my point of purchase and exchange for a new one.  I’m not too familiar with RAID configurations and what can cause these failure messages.  Is it truly hardware related, or can there be any setting or config between computer, OS, apps and drive array that can cause this.  The drive works perfectly, and like i said the utility shows it’s healthy, but I can’t take the chance of getting this message over and over and then something catastrophic happens.  I use this My Book Duo to store my Lightroom pics, other massive file folders and my  Time Machine backups.

If my exchange unit array does the exact same thing, I’ll have to assume it’s not stricly hardware related.  If so, WD needs better quality assurance teams.

RAID Stripe has failed.jpg

no fix yet. I contacted WD and they sent me out a new unit. I wasnt happy that the drives and enclosure are marked that they are refurbished though. Ive transfered all the files and Im going to let it sit for a few days to see if it does the same thing. this is the other message Ive recieved as well.  Screen Shot 2015-01-29 at 7.30.46 AM.png

I’ve talked to WD Support, and even had a desktop share with an analyst.  They feel the issue is not with the unit itself, but rather the issue is in their WD Utilities software, that is throwing the RAID Stripe Error message in error.  He assured me they are working on the solution for this, and will get back to me when they have something to share.  I’ve been using my second unit for weeks now, periodically getting the error message, but the drive is working perfectly.  I have to agree, that the issue is more than likely software, not the hardware. 

I have the my Book duo since Friday and my Mac Mini woke up this night with the same error msg. I am running Yosemite and Raid 1: a stripe set error is not applicable for raid 1 only for raid 0. I will Test the drive during the day and contact the support, but i think it’s something related with the wd tool and Yosemite. The drive seems To work fine…

I have the exact same problem—only, it seems, when the screen locks or overnight.

Is there some consensus from Tech Support that this is a software issue?

If so, when is a fix expected?

wills11 wrote:

I have the exact same problem—only, it seems, when the screen locks or overnight.


Is there some consensus from Tech Support that this is a software issue?


If so, when is a fix expected?

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

Ditto here. I’ve been getting this error message every few nights. The drive shows as healthy.

I use my Duo exclusively for Time Machine backups but considering that this happens at night I’m wondering if it has something to do with the machine going to sleep or waking up for Time Machine…

Is everyone else using their Duo for Time Machine backups?

Same thing here. WD was great in sending out a replacement drive, because my first was experiencing the RAID errors, as well as almost daily dismounts from my iMac under Yosemite, even though I never ejected it (the error was always that it had not been ejected properly, even though it was always mounted). The drive seems to be running fine, and the ejection error seems to be more a Yosemite issue than a hardware issue, but I’m not sure about the RAID error except that Disk Utility and the WD Utility both say the drive is fine.

Either way, my WD Duo is where most of my media files are kept, it isn’t being used as a Time Machine. My TM isn’t big enough to also back up the Duo files, so I’m now using Backblaze as an online backup solution, just in case.

I am having the same message with my RAID drive. The first time, about a week ago, I ignored it. This morning I did the various checks WD Drive Utilities offers ; they identified no problems.

So, WD, what are you doing about this? I have just upgraded this software, but the first occurence was before the upgrade.

No the first time this Utility software has created problems - remember when it wiped my drive???

This drive is not being used for Time Machine. Another older WD drive used for that is not showing problems. The troublesome drive is relatively new.

This entire thread is made up of irritation and no resolutions. Here’s what I know, so you can stop worrying.

  1. This error occurs within WD Drive Utilities on a Macintosh computer
  2. This error only occurs after the workstation has been put to sleep
  3. This error also occurs on non-RAID drives like the My Passport Ultra, which is extra special
  4. You don’t actually need WD Drive Utilities to use your hardware
  5. Delete WD Drive Utilities, you can always re-install it later as needed

Summary: This error occurs because WD Drive Utilities error traps a RAID check function when the computer wakes up from sleep. The error occurs because the USB drive has not yet powered on. It’s a really dumb bug, which WD should be responsible enough to resolve.

Five years later and the only way to use WD External drives reliably with MacOS is to use the WD Drive Utilities uninstaller and completely remove this software.

Up until now, the only workaround I had found to use WD drives was to ensure they were never connected to the computer when it entered it’s sleep state.

Thankyou Ian_Armstrong for your succinct analysis and providing the solution to this problem but WD really should have resolved this issue themselves years ago. It must have cost them a great deal of money replacing hardware when the only fault is a bug in their software.