My book drive working in windows 8.1 not windows 7

I’m having some issues with a usb 3.0 3TB my book drive, It works fine in windows 8.1, drive is detected and partitions
show up correctly, I ran a check disk on it, and it shows as ok, I ran WD Data lifeguard diagnostics on the drive and it
passes the smart status test and the quick test as well. However with windows 7 its completely different, under disk management the drive shows up as unknown and must be inititated, I ran a partition program on it and it says bad disk, and your own data lifeguard software says too many bad sectors.  If it was like this on both windows 7 and 8 I say the drive is bad, however the drive works perfectly fine only in windows 8, however I have no issues with any other drives in either version of windows.  Anyone have any ideas?

Hi there and welcome to the WD community.

I would recommend trying to use a different USB cable on the computer, also try to verify what happens when you connect the power adapter directly to a wall outlet to see if this makes a difference. In case this does not change the situation, I would advise to contact support for further assistance on this matter:

This is an update, something is amiss with the auto drive unlocker, when I boot windows 7 and look for my drive I only see the virtual drive from the hard drive with the WD Unlocker utility, if I run the utility, no real info comes up about the drive, but when I look back I can see my drive and its partitions and my system is reading it correctly, it seems to be an issue with the utiiity to automatically unlock the drive, when I click on the desktop shortcut for wd security, it says attach a supported wd drive?   This is really strange, So the only way I can access the drive is to manually click on the wd unlocker utility from the hard drives virtual CD.  I tried uninstalling and reinstalling all of the wd software from the web site thats meant for use with my harddrive and still it only works if I unlock it manually.  Msconfig shows I did not disable the startup or services for the drive either, and auto play is running.