Mt Book Essential 2TB Not Being Recognised

Hi there

I’ve seen a heap of posts about this issue but still can’t find a resolution. Over the past 6 months I have purchased 4 of these harddrives and they each are no longer being recongnised by my PC. They are however recognised by our WD Media Player.

I’ve rang support who have not resolved the issue and suggested to return under warrantee but really, given the 4 i’ve already got have the same issue, what’s the point?

I’ve tried swapping the cables, using different computers, orginal power source, WD Data Lifeguard, but the computer simply won’t acknowledged that the HD even exists.

ANy other suggestions other than replacing them?



Weird :confounded:, when you say they are recognized by the media player, do they work fine? Or they are just recognized but you cannot play any files.

First time user of both site and external HD, I have a 2 TB drive as well that I paid someone to set up for me which was probably a mistake but I wanted it partitioned as I have 2 desktops and one laptop. I am not having trouble seeing the HD on the machines but  if I plug it into the router which I was told I could do (but not sure that is a good idea) I can’t find it on either machine. Should the Ex-HD be plugged into a routers USB port? I was told it would run continuously making it susceptible to a crash, as much as the computer. The person who Installed it did so when I wasn’t around and I don’t see all my files or operating system broken out but he assures me they are on there and I should just plug it in once a week and wait for the light to stop blinking. Then I am backed up. But if I wanted to go to the Ex-HAD and get my pictures I don’t know how to do it and as I said if connected to router I can’t find the drive e and f. e is the laptop h is desktop. I am wondering if I should have it redone by someone else who will explain to me what they are doing and how to use it efficiently.

How are you using your HD and on what? Sorry I wasn’t any help, but I kinda have the same issue when plugged into router. Router doesn’t see this as another device hanging off nework either. Even when plugged directly into either machine. I wonder if he installed the WD Samrtware. I paid for his service but had a falling out with him for not answering questions, so I may look elsewhere for help. It would be nice if I could find it here. I have read the manual but some is beyond me. 


Thanks for your reply.

When I plug it into the media player I works fine, I can watched movies etc and see everything on the drive. It’s just when I tried to edit the drive by plugging it into a computer, it’s as if it’s not plugged in at all. Nothing happens and the computer can not see it at all.

The media player was plugged into a WiFi extender but I don’t think that would have caused any issue to the HD. The most recently purchase HD hadn’t even been plugged into the media player before it stopped being recongised, I used it once on a PC and when I went back to it a few days later, same story.

I just seems weird that all 4 suffer the same fate (all purchased at different times over the past 6mths). Not sure if it’s somethign Windows 7 is doing or what. Just weird, but desperate to find a solution. 4 HD is a lot to lose.



OK so I now have to conceed! After a lot of frustrating weeks, today I randomly tried plugging in the HD to a computer and viola, it worked! So I tried each of them, and they all worked! So I tried 2 at the same time, one worked and one didn’t. Turns out it was the bloody power cable!! I must have just been using the same dodgy power cable each time I tried a different HD. Arrgh!

Problem solved!! :slight_smile:

A very happy,