MS-DOS partition not showing


I have My Passport for Mac (2TB). I made partition on it (1TB) so I can use to store my movies and tv shows on my smart tv. I tried opening it on my mac but the windows partition is not showing up. Only my Mac partition showed up. On my mac disk utility it is showing as grey un openable disk named disk2s3 MS-DOS (FAT). I run First Aid and this was the result.

Running First Aid on “” (disk2s3)

Repairing file system.
Volume is already unmounted.
Performing fsck_msdos -y /dev/rdisk2s3
** /dev/rdisk2s3

could not read boot block (Input/output error)

File system check exit code is 8.
Restoring the original state found as unmounted.
File system verify or repair failed.

Operation failed…

Any solution that I can recover files on it before I can format this as new again? The Mac partition is not really important as I only use it as backup for my Mac in Time Machine. Thanks in advance!

Hello keithmogs,

It is recommended to connect the drive with Windows Computer to check whether the data stored in the drive is accessible as the MS-DOS (FAT) file system is not supported by Mac. Mac can only lets you to perform read/write operations completely on ExFAT and Mac OS Extended (Journaled) file format drives.