Mounting Shares in Windows 10

I have a 2TB My Cloud network drive and have used it successfully with Macs on my home network.

I have a new Windows 10 laptop and want to mount some of the User Shares.

I have carried out the network bios tweak seen in another topic, and installed wd access.

I can see the drive name listed under storage, and also under media, however I don’t seem to be able to drill down into the shares inside.

How do I mount a Share on a Win 10 device?

The following WD Knowledgebase article details how to “map” Shares on the My Cloud.

If you haven’t done so already you may want to read the My Cloud User Manual ( to learn more about how to use the various features/options of the My Cloud including how to access the My Cloud using a Windows computer.

I have followed all of these instructions without luck. I can see my device name listed under storage, and I can connect to it as a media server and see the photos/videos/music folders. However when it comes to mapping the drive it does not work. The troubleshooter says it doesn’t know of a Device by that name (despite it being listed under storage). I have updated the NetBios settings and restarted and still no joy.

I noticed one difference between the instructions and my admin area. When I go into the Network and Windows section there is no mention of SMB, only a box for naming a Workgroup.

Obviously there is some small detail missing here. After all I can access files that are in the photos/videos/music folders and I can see the device listed under storage. It’s just that last bit, mapping the drive to a users share that fails.

Sounds like the unit isn’t in the same WORKGROUP as the Win 10 PC, you need to make sure they are before you can access it the way you need to allocate drive letters easily.

Same Workgroup name for both, and restarted, no difference.

I can click through from Network onto the device name and see the music/video/photos folders but the device name is still not recognised when mapping. I am using \\device\share with case sensitivity

If you are only seeing “music”, “video” and “photos” folders that sounds like you are accessing the My Cloud Twonky DLNA media server and not the file server side of the My Cloud.

Look for this MyCloud icon in Windows File Explorer under Network:

NOT this MyCloud icon in Windows File Explorer:

If you are not seeing the correct icon in Windows File Explorer then it is worth checking to ensure Windows 10 is properly configured. Some suggestions on things to check are detailed in the following post:

In particular see Windows 10 Specific Method 1 through Windows 10 Specific Method 5.


Go into the HomeGroup Settings, then click onto Advanced Sharing Settings

At the top, it says Private (current profile) and in this area you will see about network discovery options. However on the right is an arrow in a circle that allows you to toggle this section to close it. This allows you to find another section below which is called “Guest or Public”. Toggle that to open and then you can enable network discovery.

So the issue was that a Share that is accessible to Guests does not show up by default.

Relevant section is…
Control Panel > Network and Internet > Network and Sharing Centre > Advanced sharing settings > (Guest or Public)