Is MyCloud Drive corrupted? (400044 error)

I have a 6TB MyCloud Drive that’s been doing fine for a while. A few days ago, I wanted to add something to one of the shared folders. I used WD Access to open the drive in WIndows Explorer. The folder opened and listed all of my shared folders from within the drive as expected, however when I double clicked on the folder I wanted, WIndows said that it couldn’t access the folder because it couldn’t find it.

I then tried to access the folder from the browser and after logging in, got a “Path Not Found (400044)” error. Upon opening the dashboard, I found that the drive had 0 bytes of space left which was extremely odd since I don’t really use it that much. I did both a short and long diagnostics test and both passed. The light on the drive is still blue, despite the fact that I can’t access any of the folders from either Windows nor the browser. I didn’t try the mobile app, but I am assuming I’d get a similar result.

I tried doing a system only restore as maybe something in the settings had gotten messed up.

This resulted in all of the users and shared folders totally vanishing. As a test, I created a new user and user folder and set it to public. When I try to set it up with WD Sync, I get an internal server 500 error even though I’m logged in correctly with the new credentials. (I tested this on the browser).

Speaking of the browser, I tried getting into this new test folder and get the same “Path Not Found (400044)” error.

On the mobile app, it just outright says that my new credentials are incorrect and won’t let me log in at all.

Meanwhile, the drive still says it’s working totally fine.

What happened? My next step is to do a full system restore, but I am worried as to wat happened. I had a few power outages over the last month, so that may have messed it up?

Any thoughts or suggestions would be greatly appreciated. Thanks!

@Dreamcore018 Have you checked the Knowledge Base? See the link below and check out the first link in the list. See if that will help you.

Thanks for replying!

I took a look at the article there and it mentions chaning DFS settings. The issue is that I don’t know where those are in WIndows 10. THe Microsoft article that link leads to says that’s in Administrative Tools, and it’s not. Still looking for a way to possibly install that feature manually.

Still it’s strange that I would just now need to do this as I’ve been using the drive fine up until now. Did something change?

I’m currently looking at the solutions in this thread.

Not sure how much these will help though as I can see the drive, just can’t open any of the folders.

As I can’t find any DFS settings on my computer (Windows 10), I tried the TCP settings suggested in the WIndows 10 specific methods and that didn’t seem to work. Here are some screenshots that make me believe that the drive isn’t working right.

One is from my PC and the other is from the app on android. The DFS thing sounds like it’d be specific to this computer.


I’m still having an issue with this. The drive says its 100% full (which is odd 'cause I never filled it up) so I can’t update the firmware and it can’t access any of my shared folders. I’ve tried a system only reset, but that doesn’t work. The light on the drive is blue but it won’t let me do anything. All the diagnostics tests pass so I’m pretty unsure of what to do.

So does the drive sound like it’s broken or corrupted? Should I just restore it to factory settings completely?

By chance are you using WD Sync to sync files to the My Cloud? If so users have found that WD Sync may fill the free space of the My Cloud by storing copies of synced files in a hidden folder (I think it’s .wdsync if I remember right). Users have had to use SSH to access the My Cloud at the firmware level to remove this hidden folder to free up space on their My Cloud.

So I was able to get into SSH and used ls -al to get me a list of all the files and folders…what’s in the image is all that showed. I logged in with root.


You will need to move up to the top root directory. Try performing the following command: cd ..

Then perform a directory listing.

I would use cd / cd … will put you in the /home directory.

Alright I’ve got into the main folder, but shares is red and points to DataVolume. I think red means it’s an archive, but I can’t access it. If I do a cd /shares, it says it doesn’t exist. If I go into DataVolume, it says it’s not there either.

According to another post, they found the .WDsync within the mnt folder, but my mnt folder has nothing in it.

My temp folder also has very little in it.


It kind of ■■■■■ that it won’t behave like a normal drive so I can’t just hook it up to the computer and view it through a normal browser.

I think I see your problem.

/shares is pointing at a non-existing location. (/DataVolume/shares)

When you tried to enter /DataVolume/shares, you used dd, not cd. VERY VERY different command. Dont play with dd unless you know exactly what you are doing. :stuck_out_tongue:

Try the following:

cd /DataVolume


This looks different from my Gen2. Is this a Gen1? Regardless, it thinks the /shares symlink is broken, which means there is no /DataVolume/shares folder.

The output of the commands I suggested above will help diagnose this issue.

Try a du -h -d 1 from the / directory. This will tell you which each folder contains. You
then may try hat command from the /dataVolume.

You can hook the internal hard drive of the My Cloud up to a computer running Linux (or a Linux plug in for Windows) and view the contents of the hard drive.

There are other programs like WinSCP ( that can be used to view the contents of the My Cloud (via SSH) which behave similar to using a file manager. That will alleviate the need to know various Linux command line codes to navigate the directory structure of the My Cloud.

Here is what I got when I ran those two commands. I first accidentally tried to run them simultaneously. xD


I see no shares folder. I added -h so I could see file sizes in more general measurements and these sizes don’t look that crazy, yet the drive is still full.

I ran df -h in the main folder and didn’t get results that were much different.


OH WOW this is VERY useful!! I suppose as a last ditch effort (when I get the drive working) I can send files this way… at least from the same network. It also even now gives me a better idea of what’s going on now. Using both this and the command line is quite useful. I’m still having the issue, but this is very helpful!

can you give me the output of

ls /dev | grep sda


dmesg | grep sda



I suspect that your data volume is not getting mounted. This LOOKS like a Gen1. If my memory serves me right, the proper partition would be /dev/sda4. It is not mounted when viewed with df.

Sure. Just to be clear, I’m doing this from the main folder right?

Here is the first one you requested.


Second request

Final request

Let me know if that helps.

If you look at the second request. YOu will see that the sda4 partition has problems.
You need to run fsck on the sda4 partition.

Do I just do a “fsdk sda4”? What is the specific command for that? Thanks.

The command is:
fsck /dev/sda4

1 Like