Mkv problem


#1

I have a problem with my wd tv gen1 as it is not playing some new files that i download (getting unsupported file message). I did a spec check and the two files seem identical but one of them will play ant the over will not, so not sure where’s the problem. Both files play on computer with VLC. tried reseting the unit a few times, didn’t help. btw, wasn’t able to downgrade firmware either, even if i change wdtv.ver to higher number, the system doesn’t see new firware. I have 1.03.01 firware

thanks for suggestiong on how to solve this.

Specs below:

Not playing file:

*** General Parameters ***

  • Name: top.gear.s15e01.720p.hdtv.x264-bia.mkv
  • Container: Matroska
  • Creation Date: 2010-08-28 20:14:08
  • Size: 1492.0 MiB
  • Duration: 1:03:4
  • Bitrate: 3 308 Kbps
  • Encoding Library: libebml v0.7.8 + libmatroska v0.8.1
  • Encoding Application: mkvmerge v2.9.5 (‘Tu es le seul’) built on Jun 17 2009 16:28:30

*** Video Track Parameters ***

  • Format: H.264/MPEG-4 AVC
  • Size: 1.34 GiB (92%)
  • FourCC: avc1
  • Track number(s): 0
  • Bitrate: Max.: Undefined
       Average: 3 050 Kbps
       Min.: Undefined
  • Frame rate (fps): Max.: Undefined
       Average: 25.000
       Min.: Undefined
  • Bitrate mode: Undefined
  • Encoding profile: High@L3.1
  • Resolution: 24 bits
  • Width (Pixel number): 1280
  • Height (Pixel number): 720
  • Pixel Aspect Ratio: 1:1
  • Display aspect ratio: 16:9
  • Chroma subsampling format: YUV420p
  • TV standard: Undefined
  • Interlacing: Progressive
  • Encoding library: x264 core 100 r1659 57b2e56
  • Additional Parameters: CABAC: Yes
       Reference Frames: 4
       Bits/(Pixel*Frame) ratio: 0.132
       Muxing mode: Unknown@3.1

*** Audio Track(s) Parameters ***

  • Format: AC3-A52
  • Size: 86.6 MiB (6%)
  • FourCC: 0x2000
  • Number(s) and language(s): 2: English
  • Details: -
  • Profile: Undefined
  • Bitrate: 192 Kbps
  • Bitrate mode: Constant
  • Resolution: Undefined
  • Rate: 48.0 KHz
  • Channel(s): 2 (stereo)
  • Position: Left Right
  • Encoding Library: Undefined
  • Additional Parameters: Not available

*** Miscellaneous ***

  • Subtitle(s): No Subtitle
  • Metadata: Album: Undefined
       Part number:  Undefined
       Track name: Undefined
       Track name number:  Undefined
       Performer: Undefined
       Screenplayer/Writer: Undefined
       Genre: Undefined
       Encoded date: UTC 2010-06-27 22:05:19
       Comment: Undefined
       Album artist: Undefined
       Grouping: Undefined
       Copyright: Undefined

Playing file:

*** General Parameters ***

  • Name: top.gear.s14e07.720p.hdtv.x264-bia.mkv
  • Container: Matroska
  • Creation Date: 2010-04-29 12:47:17
  • Size: 1492.4 MiB
  • Duration: 1:01:36
  • Bitrate: 3 387 Kbps
  • Encoding Library: libebml v0.7.8 + libmatroska v0.8.1
  • Encoding Application: mkvmerge v2.9.5 (‘Tu es le seul’) built on Jun 17 2009 16:28:30

*** Video Track Parameters ***

  • Format: H.264/MPEG-4 AVC
  • Size: 1.35 GiB (92%)
  • FourCC: avc1
  • Track number(s): 0
  • Bitrate: Max.: Undefined
       Average: 3 128 Kbps
       Min.: Undefined
  • Frame rate (fps): Max.: Undefined
       Average: 25.000
       Min.: Undefined
  • Bitrate mode: Undefined
  • Encoding profile: High@L3.1
  • Resolution: 24 bits
  • Width (Pixel number): 1280
  • Height (Pixel number): 720
  • Pixel Aspect Ratio: 1:1
  • Display aspect ratio: 16:9
  • Chroma subsampling format: YUV420p
  • TV standard: Undefined
  • Interlacing: Progressive
  • Encoding library: x264 core 80 r1373M 4322f63
  • Additional Parameters: CABAC: Yes
       Reference Frames: 4
       Bits/(Pixel*Frame) ratio: 0.136
       Muxing mode: Unknown@3.1

*** Audio Track(s) Parameters ***

  • Format: AC3-A52
  • Size: 84.6 MiB (6%)
  • FourCC: 0x2000
  • Number(s) and language(s): 2: English
  • Details: -
  • Profile: Undefined
  • Bitrate: 192 Kbps
  • Bitrate mode: Constant
  • Resolution: Undefined
  • Rate: 48.0 KHz
  • Channel(s): 2 (stereo)
  • Position: Left Right
  • Encoding Library: Undefined
  • Additional Parameters: Not available

*** Miscellaneous ***

  • Subtitle(s): No Subtitle
  • Metadata: Album: Undefined
       Part number:  Undefined
       Track name: Undefined
       Track name number:  Undefined
       Performer: Undefined
       Screenplayer/Writer: Undefined
       Genre: Undefined
       Encoded date: UTC 2010-01-03 21:04:27
       Comment: Undefined
       Album artist: Undefined
       Grouping: Undefined
       Copyright: Undefined

#2

I also have this with some new MKV files I’m trying to play. It then causes all other files to not work until i reset the WD TV Live player


#3

The problem is it’s default is using Header Compression when mixing. To solve this:

  • Click on video track in mkvmerge
  • choose Extra Options
  • choose None for Compression
  • repeat this for all tracks (Audio, Text) before muxing

More INFO regarding mkvmerge see the following:
http://www.bunkus.org/videotools/mkvtoolnix/faq.html#header_removal_compression
http://www.matroska.org/news/compressed-headers.html


#4

Simpler solution for those who don’t routinely use mkvmerge is to go to Videohelp.com and download the older version 3.3.0…this version has header compression off by default, so it’s 1) drag MKV file into “Input Files” box, and 2) click the “Start Muxing” button.

Gotta love that in a 1.5G file, header compression in the video (which spazzes the device requiring a system reset) saves only a little over 100 kilobytes…


#5

thanks for replies, but none of the above helped. it turns out the problem is not with mkv, but with paragon ntfs for mac. i understood this as copying a good file back and forth to usb drive would render it unplayable by wdtv. it seems the problem is with paragon 7.0.2 o lower.  downloaded paragon ntfs 8 and now it is working.

just a pitty that i have to copy all the files off and on the disk for them to start working.