Media player no longer sees mp4 files larger than 2 gigs

I have 2 media players in two different locations.
the newer one, the one that no longer has netflix on it,
will not show any of the mp4 files that are on my drive if they are larger than 2 gig.
I am not saying they won’t play, I can’t tell… because it will not show up in the directory through the player.
If I disconnect the drive and plug it into the laptop, I see them, and they will play fine through VLC

Hi,

Have you tried to reset the unit to see if this helps?Please check o the following link for help with the reset process:

Hope this helps.

Yes, I have tried that. Does not fix it.

As of course there’s no reason we know of why 2gb has anything to do with it (I have files sharing that are almost 10gb) try a media library rebuild for that WDTV unit. As there have been folk here struggling on occasion to get that to happen, the most certain and easiest, method I’ve found, is Control Panel/ Network and Sharing Center/ Media Streaming Options/ then, once there, you will see show devices on local network. Uncheck the box for that WDTV. (Effectively that blocks all sharing). Switch WDTV on and let it settle, so it knows there is no share. After a short while, switch WDTV off and go back and turn the streaming to it back on. It will rebuild for sure. I hope that fixes it.