MBLD 6TB - Unable to update via Web UI and Manual Methods

Hi guys,

I’ve been having issues updating the firmware on my 6TB My Book Live Duo. It’s currently running 02.40.06-048.

It would get stuck at “Downloading… 100%” with a White/Purple LED for hours when updating via the Web UI. Had to reboot the drive via SSH to get it back to Green LED.

I’ve also tried updating it manually with the .deb file on the Web UI and I’d get this error:

31144  - Error updating firmware: Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance.

I tried contacting WD Support over email and I was recommended to press the reset button on the drive. It did nothing more than reset the default username/password of the Web UI login. They followed up and recommended me to factory reset the drive.

I’m reluctant to factory reset the drive as I have nearly 1TB of data and have no other external drives to back them up to. So I went around the forums searching for a way to update the firmware via SSH. Eventually, I found a thread that provided me with information on copying the .deb file to the drive and invoking the update script manually.

I copied the latest .deb file to /CacheVolume/update.deb and ran the updateFirmwareFromFile.sh script and rebooted the drive, all via SSH. That still didn’t update my firmware as it still reflects 02.40.06-048.

I checked /CacheVolume/update.log and it shows:

dpkg: unrecoverable fatal error, aborting:
 syntax error: unknown user 'daapd' in statoverride file

I checked the statoverride file (/var/lib/dpkg/statoverride) and found this line:

daapd root 755 /var/cache/forked-daapd

I tried deleting the line and invoke the manual upgrade script again but this time I got this:

dpkg: unrecoverable fatal error, aborting:
 statoverride file contains empty line

It seems like that’s what preventing the update. Does anyone have any solutions to this?



Yep that is correct for that file

daapd root 755 /var/cache/forked-daapd

 What are that fles permissions set to on your DUO?

The file permissions for /var/cache/forked-daapd is 755.

I can’t see your picture, but permissions are good. Try editing the file to

root 755 /var/cache/forked-daapd

 Then try running the update again

Edited and ran the update script again, got this:

dpkg: unrecoverable fatal error, aborting:
 syntax error: unknown group '755' in statoverride file

It seems like user daapd is missing on your system. I’m trying to see how we can fix that

Seems to be the case as I did a “cat /etc/passwd” and couldn’t find daapd in the list of users.

I disabled iTunes server in Web UI, so I’m going to try enabling that to see if daapd gets created…

It’s got to do with the itunes music server I think

Yeah you should have an entry like this in the passwd file

daapd:x:501:1000:forked daap daemon,,,:/shares:/bin/sh
1 Like

I tried enabling DLNA and iTunes server via Web UI but still no sign of that daapd user being created…

Try editing the passwd file and adding my line

1 Like

Just did that and it seems like update is now running… will revert the final status/conclusion once it’s 100% upgraded.

Ok, hope it goes through… Fingers crossed

Here is a Factory Virgin MyBookLive DUO passwd file just for comparison purposes

root:x:0:0:root:/root:/bin/bashdaemon:x:1:1:daemon:/usr/sbin:/bin/shbin:x:2:2:bin:/bin:/bin/shsys:x:3:3:sys:/dev:/bin/shsync:x:4:65534:sync:/bin:/bin/syncgames:x:5:60:games:/usr/games:/bin/shman:x:6:12:man:/var/cache/man:/bin/shlp:x:7:7:lp:/var/spool/lpd:/bin/shmail:x:8:8:mail:/var/mail:/bin/shnews:x:9:9:news:/var/spool/news:/bin/shuucp:x:10:10:uucp:/var/spool/uucp:/bin/shproxy:x:13:13:proxy:/bin:/bin/shwww-data x:33:33:www-data,,,:/var/www:/bin/shbackup:x:34:34:backup:/var/backups:/bin/shlist:x:38:38:Mailing List Manager:/var/list:/bin/shirc:x:39:39:ircd:/var/run/ircd:/bin/shgnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/shnobody:x:99:1000:nobody:/nonexistent:/bin/shlibuuid:x:100:101::/var/lib/libuuid:/bin/shsshd:x:101:65534::/var/run/sshd:/usr/sbin/nologinntp:x:102:104::/home/ntp:/bin/falsemysql:x:104:108:MySQL Server,,,:/var/lib/mysql:/bin/falsestatd:x:105:65534::/var/lib/nfs:/bin/falseavahi-autoipd:x:106:109:Avahi autoip daemon,,,:/var/lib/avahi-autoipd:/bin/falsemessagebus:x:103:106::/var/run/dbus:/bin/falseavahi:x:107:110:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/bin/falseftp:x:108:1001:ftp daemon,,,:/srv/ftp:/bin/falseDebian-exim:x:109:104:Debian exim,,,:/nonexistent:/bin/falsedaapd:x:501:1000:forked daap daemon,,,:/shares:/bin/shguest:x:500:1000::/shares:/bin/shadmin:x:999:1000:System Administrator,1,,:/shares:/bin/sh

There appears to be a bug in the forum software that won’t let the line in BOLD text to show up properly

Between www-data and x there should be a :


Thanks to creativezane for pointing the bug out :slight_smile:

1 Like

Update successful! Firmware Revision is on 02.42.02-012 now! Data and everything looks fine! (:

Thanks for the “Factory Virgin” MyBookLive DUO passwd file, I’ll go double check on my passwd file!

Great! I’m glad we were able to work this one out together :slight_smile:

1 Like

Yeah, I’m really glad we worked it out too! ^^