Itunes server doesn't work anymore

Hello everybody,

is someone facing the same problem I am?

When I launch Itunes 12.1.0.50 I can see the WDMycloud in the list of the shared places where the Itunes stuff are. (clicking on the top left icon, the one shaped like a house with a note inside, a menu appears wih the WDMycloud present there).

When I click over the WDMycloud Itunes begins searching for the media over that disk, it finds them and show them. But when I try to open one of them, for example if I try playing a song, nothing happens, it looks like the “play” button doesn’t get pressed at all… I don’t know if this has to deal with an upgrade of the operating system, (MAC OSX 10.10.2, of Itunes 12.1.0.50 running on the MacBookAir thay may have been done or of the firmware of the WDMycloud) since everything was working fine…

The Apple support team tried searching for a problem in the system but the conclusion was “everything is OK, it may be a problem of compatibility of the latest OS or of the latest Itunes with the latest version of WDMycloud firmware…”

Any help would be appreciated.

Thanks,

Massimiliano.

Hello,

Take a look at this link. Hope it helps.

iTunes server and how it works on a WD Network drive

Hello,

thanks for your help but unfortunately it didn’t solve my problem…

Even if the configuration appears quite different from what is shown in the tutorial because the version of Safari is the latest one (different from the one used on the tutorial) I want to underline that it was working perfeclty until a few weeks ago, so I suppose that the configuration is OK. I suppose that some automatic update has caused some change in the system that prevents it from working anymore…

So my question was simply if someone else is suffering of the same problem and knows how to solve it…

thanks again,

Massimiliano 

Hi,

I’m having exactly the same problem, I’m running the latest firmware (WDMyCloud v04.01.00-408 : Core F/W) on my 4TB. iTunes is up to date and can see my cloud in the dropdown option, next to the music icon/button, music files show up, but pressing the play buttom does nothing. I’ve tried reseting the WDCloud, rebooting it, rebuilding the database, nothing helps.

BTW I have the same itunes server (forked-daapd) in my router (N66U with tomato firmware) and it works flawlessly.

Thanks

I had to log into the Twonky service (port 9000 of your WD My Cloud) and initiate a rescan that way to get my iTunes to stream properly.  I just wish there was more meta data from the server, but I can at least listen to the music.

Same problem here, it seems the problem is due to the latest iTune update.

I can confirm the issue is related with the last version of Itunes. Installing a previous version solves the problem.

Thanks,

I’ll contact the Apple customer service the get an earlier version of Itunes and I’ll close the topic if solved.

Thanks again,

Massimiliano.

same problem for me…

Same for me and it took me a day of restoring everything in an attempt to get it to work. This is a core functionality for which I acquired MyCloud.
Reverting to an older version may well solve the problem but new purchasers are not going to be aware of this. I foresee a lot of calls for assistance.

1 Like

Same here.

any workaround except of Itunes downgrading?

Same problem. Just bought the WD My Cloud and loaded my music onto it. Itunes will display the library, but nothing happens when I click play. 

I haven’t been able to verify an earlier version of iTunes works, but I really don’t want to have to downgrade as a workaround.

yep, same problem here. i got the latest iTunes and can’t get the server to work. at one point I managed to get my music library showing in Itunes, but i couldn’t play any tracks. if i doubleclicked a song it said “connecting to url” and then nothing happened.

this is annoying.

Just further updated to latest I-tunes ( 12.1.1.4  ). Forlong hope that the problem would be solved, but still unable to play frm the MyCloud drive, although all items appear on I-tunes.

 “it may be a problem of compatibility of the latest OS or of the latest Itunes with the latest version of WDMycloud firmware…”

My suspicion is that Apple have changed the API on their iTunes library, and the library on the MyCloud is no longer compatible.  I’m afraid Apple have a long history of this sort of behaviour, and it’s one issue of dealing with the ‘walled garden’, proprietary, control freakery of the Ghost of Steve Jobs…  MediaMonkey regularly has to revise its code to track the changing file format used to communicate with iThings.  I had to upgrade one of my MM installations yesterday, to catch up with the API changes of iOS 8 on my iPad (I had deleted all the music off it to give me enough space to install iOS 8 so I could run the MyCloud app, which needed iOS 7+, only to find that my iPad got slower, and regularly hangs now; great Job, TGOSJ…).

The fact that this problem has arisen on an iTunes upgrade hints at an Apple problem, although it might also be a failed iTunes upgrade; it might be worth trying to reinstall the failing version.

It would be nice if Apple communicated API changes to corporate ‘partners’, but I suspect they would rather you bought an Apple product than a WD product…

There are alternatives to the inscrutable, control-freak behemoth that is iTunes:

https://www.google.co.uk/search?q=itunes+alternatives

I think one of the most compelling illustrations of iTunes’ many faults is given at the end of this page:

http://www.wondershare.com/apple-software/free-alternatives-to-itunes.html

will this ever work again? i don’t know about you guys but i feel just a tad ripped off.

We now have a patch to fix this issue.  You will need to contact support to apply the patch.  Below is the contact information for WD’s Support. You should contact them by phone.

Contact WD
http://support.wdc.com/country/index.asp?lang=en

Bill_S

  Just got off the phone with WD Support and they had no clue about this issue.  How can I get this patch applied so I can keep using my WDMYCloud as a iTunes Server?

yeah same here, support offered little help I’m afraid, just told me to rescan my files. 

Sorry, I was out yesterday.  I’m looking into it.