Interface OS5

I have updated to OS 5 firmware - in OS3 app on mobile devices and could see contents from WD mycloud. Like films etc.

Just sharing my experiences for others.
First off the older OS 3 app, RAF files no preview was the standard experiences.

Now OS 5 the experience is great. I can see older images in RAF format.
Who knows maybe even see PNG and a PSD (this is on a tablet)

Just a little concerned WD big brother are snooping, as you have to agree to WD TC’s.

Other apps I have used before to see contents on the WD my cloud.
All still functions. And to my knowledge no data reordered.

So the question has to be asked what advantages am I seeing by using the WD app ?
Compared to the other apps I use to view contents on the My Cloud WD?

Your feed back is welcome.

The privacy aspects of the WD apps has been concerning for a number of people.

Personally, I find the feature set of the OS5 web apps very limited. . .large folder data managment is non-existent. The “album” experience downright useless. This is definately not a “one drive” experience.

My prefered method for web access is via a VPN. . .which unfortunately works for PC’s - - -I have not gotten it to work yet (although I haven’t really tried) for tablets.

Thank you for the reply Nas -user,

Yes limited features for an update.
Pic in pic mode, I would have liked.

Just wondering if I disconnect the phone line and try to open say a file from the WD.
Using a tablet or phone over Local area network.
Would the WD still play a video?

Or is it a requirement to be going to WD OS5 My cloud over the web to come back into my home, so I can read the WD drive.

If so that be like using a drop box or cloud and not a home cloud.
The more I write the more I become concerned at the privacy.

Perhaps a more senior member who runs this forum could post here please.
A document to explain in details better, and re assure our concerns.

After all “data leaked includes personal information from 533 million Facebook users in 106 countries, Facebook decided not to notify over 530 million of its users”

Who to say this is or may happen to WD users ?

So - clearly WD is not trying to setup a “personal cloud”.

I have a suspicion where WD is going. . . .but I do not know.
Where I think it is going is definitely not for a one-drive or DropBox functionality.

. . .from a privacy point of view. . . .these devices want far too much web access for my taste. Look no further over the hub-bub regarding the HTTPS redirect functionality.

The feature that you’ve been waiting for is available in 5.11.112. You can now TURN OFF the HTTPS redirect.


^- - – and I do appreciate that the “off” button was provided.

It was a nice acknowledgement of the complaints generated by a number of users, including myself.

Pity they also have removed telnet access in that update.
No means of going back to OS3 now.
That is in itself is enough for me to be getting very concerned the direction WD are going with this.
Still I’ve being using computer tech since 1986, and spent a small fortune over the years, I think you can guess how much money will be heading in WD’s direction in the next 20 years over this fiasco!

Some have apparently found a way to roll back to OS3 anyway on some My Cloud units. Use the forum search feature, magnifying glass icon upper right, if you haven’t already to search for a number of past discussions.

For example:

Hi Bennor,
Have tried both telnet into device and dd if=/dev/zero of=/dev/mtdblock1 via ssh neither works anymore. With the latest version of OS5 they have locked it down and nothing I have tried including pulling the drive using usb boot, or the above code in ssh work, it does not allow you to revert back anymore.
This is how cynical WD are in getting everyone to stay on OS5 for the future money cow we will become.
After using computer tech since 1986 I think you can guess how much business I will give to WD over the next 30 odd years over this.

Depending on what My Cloud Model you are using you may be able to pulled the drive (for example if using a single drive My Cloud model) from the My Cloud enclosure, attach that drive to a computer using a USB to SATA adapter or USB to SATA docking station or a spare SATA port on the computer. Then using Linux (either in a VM or a Linux boot disk/USB flash drive) and issue the commands via the Linux terminal that one would otherwise issue via SSH to roll back. Then put the drive back into the My Cloud enclosure and hopefully it will boot to the WD Recovery mode where one could then flash the OS3 firmware.

Tried that already, all I get is the “raid” web page stating drive damaged then reboots back into OS5, drive healthy!
No recovery mode.
version 5.11.112 has locked the device down.

For the single bay second gen My Cloud one can always go the “unbrick” route and re-partition and reformat the drive to get OS3 back on it. Backup all user data first of course. User Fox_Exe has some directions many have used.

Second gen Single Bay My Cloud:

Not sure if something similar could be done on multi-bay My Cloud models. All depends on where the firmware for the My Cloud is stored. If on the hard drive like the single bay model then one may be able to unbrick the drive and restore OS3 to it.


I am wondering if anyone else can verify these items.
I am at least three versions back on OS/5. . .and therefore cannot verify myself.

This will have no help what so ever, but thought I share.
The SSD WD wifi drive for the use with camera in the field - These drives have no updated OS 5 - So my friend tells me as he was confused to what I was asking about the update.
So quick question the OS 5 would appear to be for home My-CLoud drives only ?

Hi Bennor,
I’m presently backing up the drive to try just that should work. (fingers crossed)
Bit of a faf but if it works I get to use my drive a little longer allowing a bit more time to look at getting a Synology or Qnap as a replacement, I’ll never then have to deal with the sh**e from WD ever again.