I turned my 1TB external hard drive to a 2.85MB mass storage device

Hello there!

I have an Elements 1TB external hard drive with lots of important files in it. Today I was watching a youtube video on how to download Linux mint to a USB and I had no idea it had to be an ordinary empty USB. So I used balena.io/etcher/ to do the whole procedure and after flashing I realized my 1 TB external drive was converted to a 2.85MB mass storage device!!! I cannot afford to lose all that data! Can someone please help me??? Thanks!!!

Vassiliki

Totally agree Vassilki !
I’m the kind of person to follow instructions step by step and never rush …
I can’t understand this problem and I don’t want to fiddle with third tier solutions
I bought a product, followed the exact guidelines …IT SHOULD BE FUNCTIONAL RIGHT AWAY.
No clear explanations or updates to install from Western Digital I’m sending it back within a 1 week !
I just connected an old 1Tb Western Digital P/N WDBABVxxxxx … Backing up both from Local HD and Dropbox and it works like a charm.
Go figure.
@+

Thanks for replying!

Well Sorry that wasn’t really helpful :confused:
Just like you un-installled every add on software from Western Digital, cleaned the unused API in the Reg Sytem and started all over …
Tried to switch HD Driver pilot under this “unrecognized” HD Storage under Windows 7 but to no avail !
I’ll give a last chance and return the item as not “functioning” and ask for a replacement.
I really don’t have the have time to go the "nuts and bolts’ is the cable if right or not … really.
Such a disappointment with this product for 90 €
@+
Henri

Well, mine was working just fine, except sometimes I could not eject it without shutting pc down. It all happened when I tried to download Linux on my external drive instead of taking a common USB stick…So stupid of me!

Vassiliki,

I got over the procedure not extensively at any PDF documentation - useless I won’t install any add-on software from WD atm - but here in the community
So I guess it might be useful unless you mind to lose your data

It suddenly hit me :
" Just like when I play DSD Albums in Bit Perfect “Bit Perfect” : DSD in DoP Format - Dithering mode : Bit-exact Dithering ---- I had to bypass all Windows Drivers ! "
That’s was funny (for me).

It also works perfectly with Allway Sync Ver.18.4.8 pro (20$) to repatriate any files from any location to another I have !

@+
Henri

Hello again, Henri!

Thanks for taking the time to write!
Actually, losing the data is what I mostly care about, because it was hundreds of GBs. I also sent WD an email but no response so far, maybe they’re busy, who knows.

Vassiliki