I have a My Cloud it is NOT hibernating

What should I do?

The My Cloud does not hibernate. It does sleep after 10 minutes of no disk activity. You
can tell the disk is sleeping or in standby mode by looking at the led in the front of the device. It will
be blue and blink or fade on and off.

RAC

Have you enabled Sleep in the WD My Cloud Dashboard > Settings section?

Do a subforum search (via the magnifying glass icon upper right) for “sleep” and you’ll find numerous threads discussing the failure to sleep for long periods of time and some possible workarounds to the issue.

Yes, I have enable.

I am afraid you “came to the wrong place at a wrong time”. Here noone will help with MyCloud as noone can fix the hardware/software that WD prepared for this (let’s not forget) low-cost NAS.
As you have been told, there are numerous threads on why MyClods do not sleep. Often it’s because it’s been just fed with files and has to scan them. Sadly, it does not handle scanning errors better than a moron trying to fit in a square peg in a round hole - trying to do the impossible over and over.
Sometimes something is using the NAS for data - doing backup, scanning files etc.
And sometimes it just so happens - noone knows why.
For some users (like one writing in this thread) MyCloud works as intended and they come up with theories about what is happening while we all know it’s WD being unable to make a racing car out of a Ford Festiva. They think that if their drive works fine, yours should, too, but you just do not know how to make it. It’s not true.
For me it works when it’s set NOT to sleep: because (a warning) when it does, it wakes up several times per hour and the solutions people give either do not work for all or at all.
What happens when you spin a drive up and down numerous times, we all know, too: they wear out much quicker.

If you have everything setup for it to go into sleep mode then watch for the front light to blink as stated in prior post. See my You Tube video of mine.
https://www.youtube.com/watch?v=upCZW9VRT1Q

When I first bought mine it went into sleep mode often then with each firmware update it did it less often. Here lately with the latest firmware update I have noticed it going into sleep mode more often and staying in it longer. I have Version
v04.04.03-113.

The problem with the sleep mode is unless one watches or records the front LED there is no way to know for certain for how long the My Cloud is going to sleep mode and remaining in sleep mode.

One can use Rac8006’s Sleep.AWK script to get a more detailed idea of how often and for how long their My Cloud is actually sleeping.

https://community.wd.com/t/new-sleep-awk/153431

There are several services one can stop to try and improve sleep time. However, disabling or stopping those services will affect certain My Cloud features like being able to search using the WD mobile app or the creation of certain image thumbnails for files.

Here are several threads that discuss various methods to improve sleep time with mixed results.

https://community.wd.com/t/mycloud-wont-sleep-after-update-help/96645

https://community.wd.com/t/mycloud-does-not-go-to-sleep-standby-perhaps-the-solution/158591

https://community.wd.com/t/this-resolved-my-cloud-sleep-mode-issue/157059

https://community.wd.com/t/wd-my-cloud-randomly-wakes-up-the-drive-when-drive-sleep-is-enabled/152748

So there are many solutions and each year one or two more solutions that “finally work for me” appear and it is exactly a proof there is no solution.

Your are right every year new solutions are needed. That is because the firmware is
updated at times. When I first got my unit. It could only wake up at 03:00 day atop was not being used. Then the firmware was updated and atop now runs every 8 hours. Also we have not found all of the reasons that it wakes up. When not being used.

RAC

In addition to what Rac8006 said, another potential cause for the inability to sleep could be due to some other device on the local network that polls the My Cloud triggering it to wake up. Because of the variety of hardware and settings within the My Cloud itself there are any number of causes that lead to the My Cloud not sleeping for long periods of time.

It would be nice if WD would provide a Dashboard setting to allow people to choose the time out value for the how long the My Cloud remains awake. Right now it appears to be fixed at 10 minutes (at least with my unit). So in my case when the unit wakes up periodically it waits 10 minutes before going back to sleep. If there is something (either within the My Cloud firmware or on the local network) triggering the My Cloud wakeup and it occurs in less than 10 minutes it causes the My Cloud to rarely sleep.

Bennor
The standby time is stored in the file /etc/standby.conf.

RAC

Yes, know that. :wink: But as indicated in my post it would be nice if WD had an option field on the Dashboard so one didn’t have to use SSH to change the value.

I agree that the reasons can be plenty, but most of us have tried disabling the devices that could be polling the MC before complaining. If you turn off remote access, local machines (incl TVs, laptops, PCs etc) technically it should sleep a few hours before it goes into some maintenance jobs etc. Not a chance, it’s 1 min, 4 mins, 10 mins, 1 hr, 1 min, 30 sec and so ad infinitum.
It is also strange that every firmware update a new reason for wakeups arises. As if WD didn’t want us to put it into sleep mode. It’s so akin to, say, Apple trying to plug holes allowing for jailbreak rather than a bona fide developer trying to fix them.