How to access WDMCEX4100 (behind router) from the internet without WD Webclient?

Hi guys,

so I am desperate,confused and very angry right now.
I have got a WD MyCloud EX4100 device which has all my files I need for university on it. I do not want to use any web based Cloud-Service like OneDrive, Dropbox or the WD WebAccess to access my files.

So I thought since my NAS sits behind my router I can easily access it over the internet by typing “\routerpublicIP\mySharedFolder”. Haha nope. I even tried putting the local IP which is for the NAS in between. Didn’t help either, what a surprise.

Then I tried to connect via VPN. So I got my client running, connection established, used “\\mySharedFolder” and didn’t work. What do I have to type in?

I forwarded every imaginable port from my router to the NAS including 21, 22, 80, 443 and 445.

I even tried giving the NAS its own public IP (see how desperate I am?!) which didn’t work either.

So what [[EDITED - PROFANITY]] am I doing wrong? Is there something wrong with the way I type in the network share to Windows 10? What is the exact configuration I have to run when I have the following scenario:

I am sitting in the lecture hall of my university connected to their WiFi. I want to connect a network drive in Windows 10 which is my NAS which is sitting behind my router (with DDNS) at home?

I really want to have the NAS connected as a network drive to Windows and not transfer files via ftp or scp every time.

Thank you for helping I appreciate it. Feel free to ask and answer professionally because I am not a newbie (though I feel like one right now).



FTP needs to be manually enabled before it can be used. It’s disabled by default.

Enable FTP but use SFTP and map it to your Windows as a drive letter. That way it act like a local drive. Or you can setup VPN to act like you are sitting at home.

Thank you for the reply but I have mapped it as a “drive letter” when I’m at home. It’s “\\share” but logically that doesn’t work from outside even on a running VPN. So how would I have to mount that drive to gain access from far away when the NAS sits behind my router? FTP, SSH, Telnet, SMB every protocol I could think of is forwarded in my router and sent to the NAS. I have every single service the NAS’ web dashboard allows enabled. I bet there is something wrong with the way I try to mount the drive in Windows 10.

You can not remotely enable FTP access. You need to log into the unit’s Dashboard admin page.