How I replace the HDD of mycloud gen2

Already put disk working. Thanks for your help.

I have worked through the steps to create a new 3TB drive. I have successfully created the partitions and copied the uImage and uRamdisk files (obtained from GitHub). I have also formatted all the partitions as Ext4.

However, even though I can see an IP address and ping it, I cannot access a recovery gui page. The light blinks red-yellow. Please can you suggest a way to move forward? Should I use different uImage & uRamdisk files?

Thanks for any help and advice.

PS Perhaps I should add that I was running OS 5 when the original HDD crashed after a power cut. This probably has a bearing on the correct image files.

You downloaded the two files from GitHub? What specific link did you use? What directions were you using to perform the unbrick?

Others have backed up the files that are typically used to unbrick a second generation single bay My Cloud (P/N ends with “-10”). Note: you generally only format /dev/sda3 to EX4 (mkfs.ext4 /dev/sda3).

https://wd.hides.su/fox_exe/WDMyCloud-Gen2/
Unbrick directions: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/_Unbricking_en.txt
uImage-wdrecovery: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/Developing/uImage-wdrecovery
uRamdisk-wdrecovery: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/Developing/uRamdisk-wdrecovery

Some general information on how to revert from OS5 back to OS3.

Thanks for your reply.

I have made a bit of progress after downloading and ‘dd-ing’ fox_exe’s partition image files. Everything goes well until after the setup on the gui. Now the system tells me there is zero capacity. I suspect this has something to do with the fact that the setup requires me to set the device up for RAID, but my WDMC is not a RAID device. I need to find the correct img files, but most of the links seem to be broken.

Presumably this also explains why a firmware upgrade didn’t work either.

I’ll keep beevering away…

I just tried to access the https://wd.hides.su/fox_exe pages, but my Norton complains vehemently that these pages are dangerous.

Are they in fact safe?

Access the My Cloud Dashboard, go to Settings > Utilities > System Factory Restore and perform a System Only Restore. That typically fixes the 0 capacity error.

While i have Norton (360) installed, I don’t have the Norton web browser plugin installed due to many false positives it seems to generate on websites. If you feel the https://wd.hides.su/fox_exe/ site presents a security risk then run the website through an online virus/malware testing site. For example VirusTotal indicates its clean.
https://www.virustotal.com/gui/url/e328a0e98d36fa49097ee4ad935b5483572ae4a08b5b552e3f9522cdf4c4163c/detection

Tried that, but I still get the same zero capacity indication as shown in the screen shot.

It’s quite a challenge this!

This may shed some light.

I am still wondering if the Fox_exe image file is for a RAID device which mine isn’t. If so, I don’t know where to find the correct image files.

The gen 2 single bay OS may create a software RAID of sorts when it boots.

When following the previously posted unbrick directions make sure to follow them exactly. Sometimes one has to perform the unbrick procedure more than once before it finally works without an error.

One can try scanning the My Cloud user data partition for errors by running the following command using SSH to access the My Cloud. One enables SSH through the My Cloud Dashboard > Settings section.

e2fsck /dev/sda3

Tried that. Also tried `

sudo e2fsck /dev/sda3

Got this…

You could try redoing the unbrick process if you haven’t done so already. The directions link previously posted include two methods to unbrick. If one doesn’t work, try the other.

Thanks. I’ve gone back to the uRamdisk & uImage technique. I now get to the safescreen mode.

However, the screen never moves beyond 0% when uploading My_Cloud_GLCR_2.42.115.bin. Time to call it a day???

The 0% issue while uploading firmware after unbrick seems to come up from time to time. One can try using a slightly older v2.x firmware version and see if the upload still hangs at 0%.

https://downloads.wdc.com/nas/My_Cloud_GLCR_2.41.121.bin
https://downloads.wdc.com/nas/My_Cloud_GLCR_2.41.116.bin

Or take the hard drive, reformat it for a single NTFS partition, then proceed back through the v2.x single bay unbrick directions making sure to follow the partitioning and formatting instructions exactly, including the creation of the swap file.

Thank you. You are being very patient with me!

Do you really mean NTFS? Not ext4 (for linux)? I notice (from gparted) that all the partitions seem to be automatically formatted to ext4, without a specific format command.

I am away for a couple of days, so won’t be able to report back till next week sometime.

Charles

Yes I really mean NTFS. Pull the hard drive, remove all partitions, create one single partition and format it for NTFS. Then start the unbrick process, when you launch parted (parted /dev/sda) you use the parted program to remove all partitions on the drive then proceed through the partition creation process using the values indicated in the directions. Then one quits parted and issues the following two commands to create the swap file on sda1, and format the data partition sda3 for EXT4.

mkswap /dev/sda1
mkfs.ext4 /dev/sda3

Note: If using the “Alternate Way” method, use a Linux distro (for example Ubuntu) boot disk/flash drive to boot the computer. Do not use Windows or any Windows disk management programs to create the partitions indicated in the alternate way directions.