How can I read a sharespace disk taken out of the sharespace unit?


#1

Hi,

I have a wd sharespace 2tb unit. It was configured as mirrored so each 1tb disk should be identical. (?)  The raid function on the wds appears to have failed. I can no longer access any shares on the wds, it has been working just fine for a year. However, the web interface works fine and reports that both the disks are healthy. However the following error message appears at the bottom of each screen in the web interface:

“Warning: Unknown(): write wrote less bytes than requested in Unknown on line 0 Warning: Unknown():
Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0”

Yes, it doesn’t look good.

As we do not have a current backup of the wds, I would like to access the data by some other method, do a backup then re-initialise the wds and setup raid again.

I have therefore removed one of the disks, put it into a usb-sata enclosure and connected the disk to another pc via usb. Win XP can see the drive and reports it as healthy. It actually sees 4 partitions, one of which is ~ 930gb and presumably holds my data. However, XP doesn’t assign, and won’t let me assign, a drive letter to any of the partitions so i cannot read from them in order to do a backup. All right click options in XP’s disk management are disabled except “delete partition” and “help” neither of which are much good to me.

I have also tried to use GetDataBack for NTFS, a nice tool that has saved my bacon before. If i run it over the smaller partitions, it can’t find any file systems to recover. I have just initiated it to run over the 930gb partition and it says it will take 16 hours to run (with no idea whether it will find my data or not?).

So, i’m looking for URGENT help please in how i might best recover data from the disk and back it up before inserting it back into the wds.

Sorry for the long post.

pk

Melbourne, Australia


#2

U’ll need the followings

  • a PC

  • bootable Linux on USB or CD , etc…

  • clean disk (to make a backup on it)

Connect only one of the drives or u’d better do if make a sector by sector backup

from one of the RAID disks, and after it WORK with BACKUP ONLY !!!

Connect backup disk, boot Linux.

Install RAID tools and LVM package

start RAID ARRAY

mount LVM Volume


#3

I am not conversant with Unix  / Linux so would hesitate to go down this path. Given it’s not my data, rather it belongs to a customer of mine, i don’t feel i can experiment and learn this time.

My use of GetDataBack has proven fruitless, it sees no file systems on the disk even after a 16 hour scan!

I have little other choice but to put the disks in the hands of a data recovery company, with specialist tools available such as the technique you describe. I was hoping for some windows technique or software that could do the job to avoid the high cost of employing the data recovery people, especially as i doubt if there is anything actually wrong physically with the disks.

I’ll post the result of my experiences with them!

Thks.


#4

Linux will only read the disk if it’s capable of reading EXT3 file formats.  You can also do an Advanced RMA to get another Sharespace and put one of the disks in that, with no other disks, and you should be able to download your data. to another source.  But I would contact WD for how to do it exactly. 

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#5

Hi all,

Sorry it took me a while to get around to do this, but i thought i’d let you all know what happened and how this was resolved.

As you will recall, the raid function on my sharespace failed. Unable to read the data, lots of wierd error messages within the browser interface etc. I originally asked for help on how to read the data on the disks by some other method, as i suspected that the disks were ok, it was just the raid function that had failed. Resetting the sharespace achieved nothing.

I eventually sent the disks off to a WD recommended disk recovery service. They analysed the disks and recovered all the data with no issues. Problem was it took 2 weeks and cost $1500 plus I had to ship the disks interstate (costs included in the $1500). I provided a usb disk and they copied all the data onto my usb disk and sent everything back to me. So the good news was that the data was fully recovered and safe.

I then attempted to put the disks back into the sharespace, doing resets etc. not caring whether the disks would be reformatted or not this time. But again no good. I decided that the sharespace hardware was now cactus. Fortunately it was still covered under warranty. But i had to ship the sharespace and disks to Singapore from Australia, at my expense. A couple of weeks later they returned a brand new unit with new disks. I setup raid again and copied all the data from usb back to sharespace. Life was good again.

As previously mentioned, the data was not mine, rather it belonged to a customer i support. So they were without their NAS for around a month. I had all sorts of workarounds with desktops doing peer to peer file serving etc in the interim. Presented a few challenges when attempting to resync the data and get all the latest copies of files together in the one spot on the new NAS…!

Lessons to be learned:

  • always have a reasonably up-to-date backup copy of the sharespace data on external usb disks

  • using a data recovery service is a good but very expensive option

  • maybe i should have bought a more expensive commercial grade NAS for my SMB customer in the first place

  • the WDC warranty / rma support service was very good but turnaround times were very slow, they would not send me anything without receiving the faulty goods first. Not having a local replacement service within Australia, is unforgiveable imho, and just adds to the complexity and time delays

The major outstanding question in my mind is:

  • what could i, or should i, have done for my customer to save them the cost and time delay of the data recovery part of this exercise? ie. ignoring the lack of backups for the moment… how could I have recovered their data from sharespace disks without having to ship them interstate and pay for others time and effort?  The recovery company i used, sell some software called “Easy Recovery Professional”. I was not prepared to experiment and delay recovery time but this approach has obviously cost my client more. I’ll never know if i could have installed the software and recovered all the data myself, faster and cheaper… of course i don’t have any sharespace formatted disks to experiment with now…

If anybody has any comments on this software, please feel free to let me know.

Thanks for reading this far, i hope my experience will help somebody in the future.

pk