HDD external hard drive not accessible crash windows (CHKDSK crashes)

Hello all,
I’ve got a 1To WD external hard drive that I use once every month to save my files from my windows 7 laptop.

Today I tried to plug it in to make my monthly saving but it does not work. Basically I cannot access my files. The hard drive appears in the desktop window but after a long time (around 2 min) and it is recognized as a local disk (strange!).

When I plug it in everything looks fine: no strange noise or blinking led. But then windows explorer is trying to load the files with no sucess. I cannot explore the files, I can’t open the hard drive folder which appears in the desktop window. I got a “not accessible” popup.

I already had this problem in the past with another HD and I did the CHKDSK procedure and it worked just fine. But here with this one I did the procedure once and since then it became even worst: now when I am trying to lauch again a check disk it doesn’t answer anymore… event if I wait for several hours nothing happen.

I have just noticed that the same thing happen for other procedure and other software:

1- On the prompt command I type “diskpart” and “list disk” and nothing happen when the HD is plugged. When I unplug it the command works fine.

2- I have downloaded “PC Inspector File Recovery” software and when I try to scan the PC to get all the hard drive the application crashes when the corrupted HD is plugged. Right after I unplug it the software work fine and stop crashing.

3- Same thing with “testdisk” app, with corrupted HD it crashes without works fine.

Here is what I have tried until now:

  • try to access the HDD with ubuntu laptop: fail
  • change the cables: fail
  • try on other computers: fail
  • CHKDSK: fail once and cannot be launched anymore
  • PC Inspector File Recovery: cannot be launched
  • testdisk: cannot be launched

What is complicated with my problem is that I cannot use any of the tools which could help me because the corrupted HDD is making them crash for any reason…

Do you guys have any idea ?

Thks in advance.

Unfortunately, this seems to be a severe case of data corruption, all things considered. I’d recommend contacting a professional data recovery service company about this since it seems you have exhausted other troubleshooting methods.

https://support.wdc.com/warranty/datarecovery.aspx?lang=en

This makes no sense, nor does diskpart failing to run. The operating system has nothing to do with corruption on an external drive. If there is data corruption, chkdks or diskpart will report not being able to read the drive but they should run.

When you say nothing happens, what does that mean? When you type chkdsk at a Command prompt does chkdsk load? You can type chkdsk /? to see if it loads a help screen. If you see a help screen it is working. If you type chkdsk c: /r it can sit there for the better pert of a day seeming to do nothing, but it is working. BTW…use the drive letter of your external drive in place of C:.

If you type diskpart by itself at a Command prompt it will show the operating system and return to a prompt like this: DISKPART> . That means you have to enter other commands. To get out of that screen use ctrl-C to return to the normal DOS prompt.

The only thing that would make sense is a malfunction on your external drive that is messing up the USB port, and somehow causing the OS to freeze. Either that or you have a malware infection or a corrupt OS.

Have you tried running chkdsk or diskpart in Safe Mode?