G-Speed Studio XL + Windows 11 - Not Mounting or Being Detected

Hi all,

So, I have been successfully using my G-Speed Studio XL with a Lenovo P15 Gen 2 laptop running Windows 11 via a StarTech TB2 to TB3 adapter… until a couple weeks ago. I had some automatic updates install while I was away and when I came back and hooked up my G-Speed, it would turn on, beep twice like it was booting, and then shut itself off because the computer was not detecting it. Whatever I do, I cannot get it to mount on my computer anymore.

It appears the G-Speed software utility and studio utility was missing after the updates as well. I can’t get the software to load or work anymore because it is not detecting the drive. I’ve tried all the disk management tricks, changing settings with the Thunderbolt/USB controllers and uinstalling/reinstalling them all. Uninstalled/installed all G-Tech software and the TB for Windows software from them. I tried connecting it via a docking station, which kind of worked? The G-Speed would at least stay on, but still not mount or be detected by the computer.

It’s not the G-Speed, it’s something going on with my computer. A recent update? A hardware issue? It does detect the docking station, but not the drive via the same TB port. I tried hooking up the drive to my old Lenovo laptop running Windows 10 and it would mount and read it just fine. I’ve tried everythihg short of wiping my computer and reinstalling everything, which I’ll probably do soon if I can’t find a solution.



Hi @ljland ,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: