WD external drive not showing up on Windows 8

So far I know the device isn’t broken or damaged, because it works absolutely fine on my Windows 7 PC.

It worked previously on my Windows 8 PC but now it just suddenly no longer works. Unplugging, resetting, even restarting the whole computer has fixed nothing. I’ve uninstalled the drivers in device management since that worked for some people but that didn’t help fix the problem either. There’s nothing wrong with the USB ports either–I checked those too. The disk does not show up in disk management and there’s nothing new on the device manager, but Windows does make a ding to indicate a new USB device has been connected.

Now what?

Found something in device manager though:

“This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)”

More trouble shooting has found that NO USB device with a disk on it is being recognized. At all.

Try deleting and updating the USB drivers maybe there is a problem there.


Tried this too. I haven’t the damndest clue what could have caused this.

Ultimately a system restore magically fixed everything. I’m not sure what got changed. I didn’t mess with any vital system files in that time. This is all truly bizzare.

I have one hunch on one thing that might have maybe POSSIBLY it’s-really-a-long-shot could have messed things up. I did change my power settings on my PC from “Balanced” to “High Performance” but I’ve looked at the settings and that hasn’t changed anything that should affect my USB…

Regardless, I’ll get back to you if it stops working again. For now it works but the “solution” was a system restore. I wouldn’t call that a solution.

The problem is back. It is still happening with absolutely any USB storage device plugged into the computer.

The USB ports are not broken. Other devices work in them and it has worked since my last post. The difference is my computer DOES NOT have any system restore point to fix this anymore.