G Shuttle SSD with M1 - ?compatibility issue

I have a new Macbook Pro M1.

Any compatibility issue with MBP m1?

my Shuttle does not show in explorer. but can be seen in the System report Thunderbolt.

tried to install the driver online, but still doesn’t work.

any workaround?

Dayne, have you found a solution? I am having the same issue with the G-speed studio 4 bay TB2 enclosure as well. I had Apple look into it and they said since the computer sees the drive it’s a driver issue that WD needs to fix. I reached out to WD on the 4th and still have yet to receive a response??

WD support already emailed me and asking for more details.

I just emailed them screenshots of the System Report, Disk Utility and My Macbook Pro M1 details.

So far, no solution yet.

Will message, once they give me a solution.

Sounds good, thanks!

My G-Speed Shuttle now works on my M1 MacBook Pro using the new Promise driver! Hooray!

Download from here -

All the drivers are the same I think (R_MacDrv_V6_2_16).

Follow the instructions for installing - which includes lowering boot security to load non-Apple extension and it will work. My RAID now works as before. Thank you Promise Tech!

First of all, Bless you. I just moved over to an M1 Max MBP and could not get my G-Shuttle 4 RAIDS to mount… the Promise extensions totally fixed the issue.

  1. It’s weird that WD (who now owns G-Drives) would depend on a Kernel mod supplied by another company (Promise) to get their products to mount on the what’s obviously going to be Apple’s new architecture going forward.

  2. It’s weird that WD has no mention of these issues anywhere on their (WD) or their (G-Drives) web sites

  3. It’s unreal crazy that either Apple or G-RAID (and PROMISE) - or both wouldn’t change whatever needs to be changed to conform to Apple Silicon. It’s also weird that the change to Apple Silicon suddenly changes the kernel enough that an externally mounted (through USB-C) device will no longer mount without customizing the kernel…

  4. I’m very disappointed that almost a YEAR after this problem was first brought up (and is a major usability issue) that it is apparently not resolved. I’m currently running MacOS 12.1 beta (Monterey) - it’s the latest-greatest.

  5. I’m guessing that I have to leave my boot security in the “reduced” setting until this is actually properly addressed (to get Promise’s kernel extensions to properly load)? That is certainly not a happy state.

The reduced security mode will be permanent until the driver model they use changes substantially. Apple has given years of warning to developers regarding this issue.