G-DRIVE spontaneously ejects while Time Machine Backing Up

I bought two 4 TB G-DRIVES. I copied the files from my former external drive onto one of the new G-DRIVES and it works fine. I set up the other G-DRIVE as a backup with Time Machine. Time Machine begins backing up my internal and external hard drives, but after a while, the drive ejects. I can fiddle around and re-mount it and it will continue to back up for a while and then eject again.

I deleted my G-DRIVE as my backup drive in Time Machine and selected it as my designated backup disk again but the same thing happened during a number of re-tries. It says it is backing up but after it says it’s backed up 50 or 100 GB or so, it spontaneously ejects.

Any help will be appreciated.

Thanks.

Are you using the new OS Mojave?

If so there are a few known issues on 10.14 with Time Machine backups and certain applications on the computer. There are forum posts all over the Apple support forms about it. One app in particular that is quite popular named AppCleaner has an issue with this as well. Basically you need to exclude certain files from Time Machine backups in the options in order for it to complete a backup.

You will want to consult with Apple in this case to determine what might be the issue.

If you are not on Mojave 10.14 yet then it could be hardware related but usually unlikely. How long does it go for before it ejects? is this mere minutes or seconds or quite a while?

If it takes a bit of time then you can check your System Preferences and make sure the checkbox in Energy Saver for “put hard disks to sleep when possible” is unchecked.

Thanks for getting back to me.

The Energy Saver box was checked and I unchecked it. Unfortunately, it didn’t help.

Here, again, is what’s happening: I click Time Machine to back up my internal and external drives and the backup drive starts clicking and blinking. Time Machine will say something like "backing up 104 Mb of 720 GB and the backup drive clicks for a while. Sometimes it will only be 10 minutes, sometimes longer. Then the drive will spontaneously disconnect. When I unplug and re-plugin the drive, my MacBook Pro will see the disk again. Time Machine will be saying something like “Waiting to finish download” when the disk has disconnected. When I reconnect the backup disk, Time Machine will go back to saying it is backing up stuff again, but then sooner or later, the disk will disconnect again.

Here’s a more specific description of the last time I tried to get the disk to back up: I reconnected the disk and both my external drive and back up disk were quiet for about 4 minutes. Time Machine said “Preparing for Backup”. Then both disks blinked for a few seconds. Then the external drive disk fell silent and the backup disk blinked and clicked away. The external drive disk blinked a few times but mainly stayed quiet. This time, Time Machine said it was backing up X bites of 288.90 GB. Over the course of about 10 minutes, this continued. Time Machine got to the point where it said “Backing up 860 MB of 288.90 GB”. At that point, the backup disk spontaneously disconnected.

I’m suspecting that the disk is faulty. Unless you have another suggestion, I’ll try a different D-DRIVE USB. I bought 3 of them to go from my present 2 TB set up of one external disk and two backups (along with Backblaze) to the same setup with 4 TB. I am using one of the new G-DRIVES as my external disk drive (and it’s working fine). Unless you suggest something different, I’ll unbox the third D-DRIVE and see if it works with Time Machine.

Please look this over and get back to me about any new ideas to get this drive working or to unbox the third drive and try it.

Try just running a looping speed test on the drive for a few minutes and see if it disconnects.

Download Blackmagic or AJA system test and run it on the drive, change the settings to make sure it does it continuously so it can go for 20+ mins and see if it maintains a connection. If it is staying on then the issue is not with the drive.

This type of speed test would be stressing the drive to the brink and would be way more than what Time Machine does to it. The next step would be to erase the drive and try the backup from scratch if you haven’t done that yet.

Blackmagic Speed Test won’t test my disk. Here’s my screen shot:

This is the symptom of a corrupted disk. The partition on the drive has made it read-only and you will need to erase the drive in Disk Utility.

Okay. Good to hear you have a diagnosis. I’m away on a photo shoot all week but will do it when I get back and check in with you. I just erase the disk and try to back up again, right?

I opened Disk Utility and had it erase the disk. After about 10 minutes of the disk operating, I got this error message from Disk Utility. What should I do now?

Make sure you’re using the correct power adapter first of all. If it is one of our standard USB 3.0 model drives it should be a 12v 2a power adapter. If it is one of our newer units with USB-C or Thunderbolt 3 then it will be a 19v 3.42a adapter.

The format process itself should only take seconds. So the fact that it took 10 mins is an issue itself. It looks like it is beyond just slight corruption and the device should be replaced if it is under warranty still. You can create an RMA on our site here: RMA Creation

I bought 3 G-Drives to use, one as external disk and two as Time Machine backups. The one I’m using as external hard drive works fine. Since I had trouble with the second one using it as a Time Machine backup, I unboxed the third G-Drive imagining that the second one was defective, as you suggested. Not so. The third G-Drive failed to backup with Time Machine just like the second one did.

I ruled out that Time Machine was not working properly. I erased one of the 2 TB CalDigit drives I was using to back up and plugged it in. It worked.

I don’t want to waste any more time than I have already, trouble shooting how to make your devices work with Time Machine. I’m returning your G-Drives and will substitute drives that are compatible with Time Machine.

Rich