Ftp remotely

Hello ,
My name is Paul and I’m new here.I just bought this Mycloud 4TB (v2 FW)
I have a couple of questions.
1: Is it possible to FTP into this nas from outside my lan(via ddns)
if so,Instructions,Please
2: I would to stream music to my note 5 from outside my lan(via ddns)
if so,Instructions,Please
I just bought this 2 days ago so ,if not I have to return it
as this is the only reason I bought it
Thank you,Paul

You should read the My Cloud User Manual (English version: http://www.wdc.com/wdproducts/library/UM/ENG/4779-705147.pdf) if you haven’t done so already. It explains how to enable FTP on the My Cloud.

Please note that FTP is NOT a secure protocol. One’s FTP login information is generally sent in the clear as is any data that is transferred between the FTP client and FTP server within the My Cloud.

In addition to enabling the FTP option with the My Cloud Dashboard one also typically has to enable and configure port forwarding (port 21 for FTP) within the router/gateway so the FTP traffic is passed to the My Cloud.

Note that FTP is generally used for uploading/downloading files/data not “streaming” media. There are several WD software and apps that will allow for remote media streaming of certain media content. Those programs include; WD My Cloud Desktop for Windows, WD My Cloud Desktop for Macintosh, WD My Cloud app for iOS, WD My Cloud app for Android, and WD Photos for Android. One can also access the My Cloud remotely using the MyCloud.com web portal to access their media.

It is possible to configure the My Cloud for SFTP access but that involves using SSH and potentially editing one or more firmware files within the My Cloud using SSH. It also involves port forwarding port 22 within the router/gateway to the My Cloud. See the following post for general steps on how to configure SFTP.

https://community.wd.com/t/sftp-setup/95350/5

I got and done all that
I can ftp into the mycloud from “inside” my lan
I can do everything from inside the lan.
My question is can and how to I set up the mycloud
to access it remotely via ftp or for streaming music
but Not using the WDmycloud site or app,because
the app and page are very primitive and don’t have the features I need
Thank you

As explained in my post, for remote FTP access you have to configure port forwarding of port 21 within your router/gateway. Consult your router or gateway’s documentation and administration interface for directions on how to enable and configure port forwarding for your particular router/gateway so you can forward port 21 to the My Cloud.

As I said earlier,I have port 21 opened up in my router
and can access the ftp ,but only from inside my lan
I want to do it from somewhere outside my lan
like my phone or from my office computer.
but I also would like to stream music from a android app
like mediamonkey
Thank you

Have you created “Users” and given them passwords? Have you used that User/Password in the FTP client software? As indicated in the My Cloud User Manual; “You must create a new user for the FTP function to work. See “Creating a User” on page 42 for information on creating a username and password.”

If you have port forwarding properly configured within the router (pointing to the IP address of the My Cloud) and you have FTP enabled (set to On) via the Dashboard > Settings > Network section. Then you need to use your internet IP address (not your local network IP Address) to access the My Cloud FTP server. You can google “what is my ip address” to find out your internet IP address.

In certain rare instances its possible one’s broadband provider may block the FTP port (or multiple ports). If this is the case then you can use the router port forwarding to route an alternate port to port 21 on the My Cloud.

Please note that streaming media remotely is only officially supported by the WD apps and software. Any other methods we may try to use may require additional configuration of the My Cloud. Its important to remember that these single bay My Cloud devices are very basic, have limited features/options and may not support certain methods of access or software without some under the hood (so to speak) editing of firmware files/settings as evidenced by other threads in this subforum that try to enable other methods of remote access.

To stream from non WD mobile apps will require the mobile app itself to support some method of FTP or similar remote access. It is not clear if the MediaMonkey app for Android supports remote access at all and if so using FTP or similar method of remote access.

Ive got the same problem. My internet provider is Virgin Media and got Super Hub 3, My Cloud is directly connected to SH3, and I’m trying to set up FTP server on it, Can access from inside the network but from outside is not possible

So my external IP is 82.20.25.XX , on My Cloud I’ve setup the static IP which is 192.168.XX.XX FTP Access is on, next to it there is a Configure option but I didn’t change any thing in there

FTP Setting on My Cloud, Do I need to change something over here? What about those ports on (Pic C) when you click Customize suddenly port numbers are showing, do I need to change them if not that’s ok, but then in next steps do I need to put them somewhere or better stick to option Default (Pic B)

One more thing IN My Cloud Dashboard I’ve got something like that

Status Internet access
Mac Address 00:14:EE:05:XX:XX
IPv4 IP Address 192.168.X.XX
IPv4 DNS Server 192.168.XX.XX , 194.168.X.XXX

Do I need to use this IP 194.168.X.XXX to connect from outside the network?, if yes then I still can’t connect.

Pic A

Pic B

Pic C

Pic D

when checking ports on http://www.whatsmyip.org/port-scanner/ it’s showing that ports 21,80,443 are open after setup up Port Forward on My Cloud but not yet on SH3, So it’s mean I don’t need to change those ports to different?

Pic E

Pic F

Pic G

After all those basic settings I can access FTP from inside the network but I can’t do that from outside, where I’m doing a mistake or not setting something up? In FTP app on my phone I’m putting the external ip 82.20.25.XX with default port 21 and got info it can’t connect. If the ports are open after setting them up on My Cloud do I need to set them up as well on my SH3

Pic H

Setup on my Phone, and still can’t connect, I’ve put external and internal IP still no joy.

In the app im putting this IP 194.168.X.XXX as well but still can’t connect when outside the network. Port 21 is 100% open according to http://www.whatsmyip.org/port-scanner/
I’ve setup those ports as well on my SH3 just in case. But still can’t access FTP from outside the network.

Pic I

Does Virgin Media allow for inbound FTP connections from the Internet? If one does an internet search for “Virgin Media FTP” one will find numerous discussions on others having problems getting FTP working properly.

If Virgin Media blocks inbound FTP port 21 then one could try using an alternate port, one that Virgin isn’t blocking.

Hi. Thanks for replay well according to http://www.whatsmyip.org/port-scanner/server/ port 21 is open after setting up Port Forward on Super Hub 3 and in Dashboard of My Cloud. Even checked on https://www.yougetsignal.com/tools/open-ports/ with my external IP 82.20.25.28 (network provider IP) port 21 is open but when I put IP 194.168.8.100 (the one from the dashboard of My Cloud as think this one is the external IP of my Device) is showing its closed but there is no way in MY Super Hub 3 I can forward port 21 on external IP (194.168.8.100) of My Cloud, because this IP I need to use to connect to MY Cloud from outside the LAN network.

Think I might Put Super Hub 3 into modem mode plug my ASUS RT-AC68U buy external hard drive and set up FTP on the ASUS as it’s much quicker and simpler to do, but that is why Iv’e got My Cloud for that to use all his features.

OR if I’ll put SH3 in Modem Mode then plug my ASUS how to set up FTP on My Cloud as there will be more IPs involved into that.

This are the setting I’ve got when set up Static IP on My Cloud not in SH3 router

Another update I went to https://ftptest.net put IP address 194.168.8.100 port 21 and my results are
Warning: Plaintext FTP is insecure. You should use explicit FTP over TLS.
Status: Resolving address of 194.168.8.100
Status: Connecting to 194.168.8.100
Error: Connection attempt timed out

Firewall on SH3 is ON

Generally to access the My Cloud FTP server remotely one would use the public IP address (82.20.25.28 for example in your case) NOT the internal IP address of the My Cloud. The router should, if port forwarding of port 21 is done properly route the traffic from the public IP address to the private My Cloud internal network IP address.

Things to check when using the single bay/single drive My Cloud FTP server.
Do not use SFTP or any sort of encryption. The single bay/single drive My Cloud units are FTP only, not SFTP.
Check to ensure the My Cloud has a static IP address assigned from the network router or configure the My Cloud to have a static IP address.
Check the port forwarding settings in the router to ensure it is forwarding port 21 to the internal local IP address of the My Cloud.
Check the network settings of the My Cloud to ensure they are correct if set manually. Sometimes it helps to use public DNS servers rather than the local network DNS server.
Turn off Wifi on the cellular device if using a cellular device to test FTP access.

Thanks again so let me understand now

To connect to My Cloud from outside I need to use internet providers IP (82.20.25.28 in my case)
No I don’t use SFTP (there is no option for encryption) in Dashboard
I’ve setup Static IP on My Cloud, as you can see on photo in previous post which is 192.168.0.17
On FTP next to it you can click to Configure more FTP settings but I didn’t change anything over there everything is default as you can see in my first post (pics A-D)

This is the setup on my router for Port Forwarding

This is what I’ve got when clicking Static option to setup Static IP

IP Address 192.168.0.17
Subnet Mask 255.255.255.0
Gateway IP Address 192.168.0.1
DNS Server1 192.168.1.1
DNS Server2 194.168.8.100
DNS Server3 empty

There is a option to use Google Public DNS maybe I should to use that instead them
DNS Server1 192.168.1.1
DNS Server2 194.168.8.100

Small Update what I’ve done:

Change Static IP from 192.168.0.17 to 192.168.0.84
Change DNS Servers

from
DNS Server1 192.168.1.1
DNS Server2 194.168.8.100

to

DNS Server1 8.8.8.8
DNS Server2 8.8.4.4

In SH3 Port Forward look like that

when going to https://ftptest.net and putting does details

Im receiving:

Error: Carriage return without line feed received
The replies sent by your server are violating the FTP specifications.
You have to upgrade to a proper server.

You do not use “anonymous” as a login name. Rather you use a User name and password created through the My Cloud Dashboard. If accessing a Private Share make sure to use a User and password that has permission (again set through the Dashboard) to access that Private Share.

1 Like

Finally I got it to work … instead of using the FTP use SFTP server with Port Forwarding 22 to any number you like and make sure to have the SSH on and set your password.
Then use any SFTP software like FileZilla, at the host use your >>WAN IP<<, at the user use >>sshd<< at the password use >>SSH Password<<, and the port you forwarding to.
Don’t forget to open the Port Forwarding at your router.
Enjoy