Flv video stream playback too fast

Hello everyone, I’m having an issue with my wd tv live and playback of flv files. The video plays too fast and gets further and further out of sync with the audio.  It’s visible on the screen that things are moving faster than normal.

This wasn’t always the case. I had the tv live plugged into my bedroom tv (1080p hdmi) and moved it to the big tv in the lounge (pal composite). When I moved it back, I noticed the faster video playback.  At that time, I did a firmware upgrade and a reset to factory defaults and it seemed to come good. A couple of days ago I moved it again to the new tv in the lounge (1080p hdmi now) and it was playing fast again. There was no new firmware so I did the reset to factory defaults but that didn’t solve the issue this time.

It’s not just 1 flv file, I tried 10 or so different ones but they’re all from the same source. Other formats like avi and mkv play fine. It was working ok before I swapped it between the tv’s so I’m expecting that its just some setting I need to set but I’ve got no idea which one.

Any ideas anyone?

mediainfo for the files

Format : Flash Video
File size : 19.3 MiB
Duration : 5mn 2s
Overall bit rate mode : Variable
Overall bit rate : 537 Kbps

Format : AVC
Format/Info : Advanced Video Codec
Format profile : Main@L3.1
Format settings, CABAC : Yes
Format settings, ReFrames : 6 frames
Codec ID : 7
Duration : 5mn 2s
Bit rate mode : Variable
Maximum bit rate : 555 Kbps
Width : 640 pixels
Height : 360 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 fps
Standard : Component
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive

Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 10
Duration : 5mn 2s
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 44.1 KHz
Compression mode : Lossy

Edited to fix wall of text

Hi, try rolling back to an older firmware version. 

Any suggestion as to which version to rollback to?  I’ve downloaded all the ones available from the rollback page.

I think I’ve traced it to the hdmi output settings.   At 1080p/24, the video is slower than the audio.  At 1080p/50 it is about right.  At 1080p/60 the video plays fast.