Firmware wont rollback properly

I’ve been trying to rollback my firmware so i can use the custom themes with moviesheets that i downloaded from here: and i tried a couple different ones and copied the files direclty to a usb flashdrive and every time i go to update the FW it keeps saying the Firmware you are attempting to install is not complete. Have no clue

Just clarify your setup at the moment please, it will help with answering.

What do you mean by setup? I plugged the usb stick with the old firmware into the wd live tv hub and tried updating it and when it rebooted and went to the upgrade scrren it was stuck on 0% then just said firmware is not complete and wouldnt update properly.

… and yout put *all* of the files on the stick? 

yes, there were 4 of them for the 2.07.17 fw and put them directly onto the stick and not in a folder.

It’s rare, but sometimes different sticks won’t work.

Try another blank stick of a different type / brand, or even a portable hard drive.

Also, make sure it’s formatted as NTFS, FAT, or FAT32.


Make sure your USB Stick Does Not have a U3 Partition.

If if does… remove it and Format your Stick FAT32.

Different stick did it, thanks!!