Firmware 2.02.32 "The system memory is running low, would you like to boot the device"

I have been using my WDTV Live for about 6 months with no problems.

My usage has been restricted entirely to streaming, wireless via DLNA.

Yesterday I decided to watch some youtube videos on the WDTV Live. They worked fine.

Today when I turned on the unit, I got message listed in the subject. I rebooted.

Now every video I watch streaming crashes the device roughly 15 minutes in. The unit completely freezes and the remote is no longer recognized and I have to pull the power cord.

After rebooting, the problem returns again in about 15 minutes of streaming. Happens on multiple files.

Any suggestions? I don’t want to downgrade the SW because it has been great for me. Is it worth trying to reset to factory settings?

I am getting very similar things happenning to my WDTV Live box except I connect my server via wired connection. 

Every video I watch streaming crashes the device after roughly 20 minutes. Unit completely freezes and the remote is no longer recognized and I have to pull the power cord.

After rebooting, the problem returns again and after about 20 minutes of streaming. Happens on all video files.

Is it worth trying to reset to factory settings?

Any suggestions?

this is a known issue

yes there is a memory leak

it’s particularly bad with youtube, but other things are affected as well

factory reset, you can try if you like

alternative reset option is here

these might help a bit

but will definetely NOT solve the memory leak, that would have to be fixed via a firmware update by WD

I performed the factory reset and the symptom, for now, appears to be gone.

I won’t be using youtube any more though since that is the only new thing I tried and was likely the cause of the memory leak.

The same issue with my two WDTV Live players occured about 2 months ago, after working just fine for many months with the latest firmware. All of a sudden both players began to crash after 15 minutes of streaming (Netflix).

Even a factory reset didn’t solve this memory leak, in my case.

After rolling back to the previous firmware version, it works fine again, no more crashes during streaming. Still going strong after almost 2 months :smiley: .

But I really honestly have to say, it’s a shame that this memory leak ‘bug’ still isn’t solved, there are more users on this forum who experienced this issue much longer than I have (and many of them still do!). Why there isn’t a new firmware version, to solve this (and other) issue, yet, is beyond me…

It worked me too Thanks, Now I have another problem I can’t get anything to appear in windows shares i’ve done everything I can think of reset, reinstall WD Discovery, refreshed everything.

Anyone wanna buy a WD Live.  :confounded::laughing:

Same problem, locks up after 30-40 mins cant play annything and needs a power off. Also will not restart from remote.

Memory low and will come up with a file type not supported messagein the midle of a file its playing?

I havent really used it since December when I upgraded it to 2.02.32 because of these issues.

I have now used the roll back to 2.01.86 and things are working again. But I can not now leave auto update on? 

Is there a later firmware that fixes this yet?

aguile wrote:

… I have now used the roll back to 2.01.86 and things are working again. But I can not now leave auto update on? 

You can leave auto update off, and when you want to easily see if there is (ever) a future update, you can view to the WD TV Live’s address in your web browser (e.g., as it will say so on the front page (I think - may have to sign in first but can’t remember offhand).


Has this issue been fixed in the firmware, or should I run this reset script still?

Mountaingoat wrote: Has this issue been fixed in the firmware ?

there has’nt been a firmware update in nearly a year … so, what do you think ?  :confounded:

I know tghis is an old thread, but I seem to have fixed my similar issue by disabling Miracast in the network configuration menu.   I also disabled NFS browsing but thet did not seem to help… though it is still off.

The change after removing miracast and NFS was instant… I noticed a significant increase in responsiveness of the device… and it was able to play several videos without issue…   Maybe the memory leak is still happening, but it would appear to be much less pronounced if so.

YMMV, but wirth a shot if it is not a feature you require.

The last week I was having the same problem, seemingly out of nowhere.  I tried raising the player, then blasting it with compressed air, but that didn’t work.  What worked is exactly what davidthenewf did.  Turing off the Wifi Direct/miracast seemed to rejuvenate the player, and it’s been flawless and much more responsive ever since.  Before the player sometimes didn’t want to turn on, and had to be unplugged and replugged.  Now it just seems to do everything easily when I hit the remote.  Before downgrading your firmware you should try this – still running the 2.02.32 firmware.

Hi all,

so what’s WD’s game plan on this? There are numerous forum posts with freezes with 2.02.32, but no new firmware for quite a while :frowning:

I am on wired network, so, Miracast / WiFi Direct don’t apply to me (unless I’m missing something). I have tried a complete reinitialization, including with a script found on an other forum, that is supposed to clean up more things compared to the default reset functionality - my WD still freezes. I am working with drive shares, not DLNA, which was by the way de-activated from all NAS devices, just to be safe.

please PleasE PLEASE WD, build an updated firmware to eliminate our freezes?

My device:

WD TV Live Streaming Media Player
Model: C3H

1 Like

Yet another great success company? The WD TV worked perfectly until the firmware 2.02.32 update. Since then as reported numerous times on this forum we face the memory leak issue which freezes the player after more or less 20 minutes. So what happens next? A serious company would have delivered a fix after some testing, nevertheless WD is just ignoring all the people on this post.
Will downgrading be the only solution? I really hope not, otherwise WD is just another company interested in selling its products and snubbing completely its customers. I still have some hope, but not for longtime anymore, so please WD fix this as soon as possible.

1 Like

David, I was having this problem, I followed your advice re- Miracast and fingers crossed, it seems to have worked. Thanks for the info.