Since 3 days netflix streaming problems

I’ve been watching netflix streams on my “WD TV Live” streaming receiver for about 2 months without any problems. Since about 2 or 3 days I’m experiencing serious problems. The first 30 minutes of a movie work fine, but then the subtitles disappear, and a few minutes later the video stream cuts out. The netflix client then doesn’t react to the remote control anymore. I have to pull the mains plug to restart WD TV Live and watch the next 30 minutes.

The issue can be replicated systematically - after 30 minutes problems appear.

I haven’t change anything in the last 2-3 days with my setup. Before last Wednesday or Thursday, everything was fine.

Any idea what this is?

(my WD TV Live runs the most recent firmware version)



It’s a memory leak bug in the latest firmware update, that can suddenly appear (read topic in link above), even if it worked fine for months. I experienced the exact same issue. I’ve tried resetting the box, but that didn’t help for me. Rolling back to the previous firmware version did the trick for me, since then I can watch Netflix without any problems.

I hope this will help you too :wink:

1 Like

Excellent! Thanks for the hint - I’ve tried it and everything works fine again.

Thank you so much for your help!