Firmware 2.02.32 Bugs (Even More)

Hi,

While I think that WD has attempted to put in some more features into this new Firmware and the player definately boots up quickly, it might have been released a bit prematurely at the cost of a decent round of testing. Bugs Discovered in addition to previous posts:

  • MOV files no longer contain audio. I can confirm that on Firmware 2.01.86 that they do have audio as I have rolled back;
  • The SiriusXM app exits out of a station randomly; Does not happen with previous firmware.
  • When switching between apps, there is some sort of memory leak, as the system hangs, then freezes;
  • Netflix screen dims when buffering content and remains dim throughout. This happens periodically.
  • Problems reading ID3 tags of MP3s. Titles, Artist Name, Album, etc. do not appear when playing MP3s files despite ID3 tags existing.
  • No way to continuously play files (ie. next file starts playing upon previous file’s completion). Only choices under play mode are repeat one, repeat all, shuffle, and shuffle repeat.

 As stated before, these should have been caught during alpha and beta testing. I have since rolled back to previous firmware, but hope that WD can fix these problems quickly, since they did work before.

P.S. Please add the Amazon Instant Video app to your new firmware release in the future. It would greatly benefit your users and put your player at the top of the list, since all of the other WD features far exceed those of other players.

Thanks,

D. Cravaccio

5 Likes

!00% with you on the memory leak

The youtube app is bad for this, sometimes making the box so slow it takes over 5 minutes to respond to a button press

The only fix is a menu restart, but that now wipes all login data

would be good if the bug reports were pinned  :smiley:

I just hope WD fixes this ASAP and that we do not have to wait 6+ months to fix these issues and countless others. Seems like this is the Windows ME or Windows Vista of releases for this box, if you catch my drift.

1 Like

“No way to continuously play files (ie. next file starts playing upon previous file’s completion). Only choices under play mode are repeat one, repeat all, shuffle, and shuffle repeat.”

Have you tried pressing “Play” instead of “OK” to play the first file?

1 Like

“No way to continuously play files (ie. next file starts playing upon previous file’s completion). Only choices under play mode are repeat one, repeat all, shuffle, and shuffle repeat”

This is a real issue for me.  I only use the folder option and not the media library.  When I now select the first file from the folder I get a new page when playing that file which shows the associated album cover.  Really don’t want this, but the bad part is that it doesn’t go on to play the next file.  Really want it the way it was before where you select the first file from the folder and it plays them all sequentially.  Will have to go back to previous version.

Also be nice if Western Digital can ever fix issue with Neflix not working right when one choses subtitles.

1 Like

Burn,

Thanks for the suggestion on the play versus select.  This is good enough for me.  I now just use play and get the files in the folder played continuously.

Thanks!

i’ve posted this elsewhere but thought the bugs should go together, plus i missed a couple:

  1. Lag in menu - really bad at one point but when i deleted a couple of recent file info’s it speeded up, but slowed down when i rescanned the files - so no information for now which is a pain.

  2. Refuses point blank to play local media after using iplayer - important in the UK because its such a fantastic service.

  3. Lost MP4’s into the music folder - audio only, had to remux them to mkv for them to show up again, there is something wrong with its recognition on the MP4’s it does see as it leaves the file extension on now in library view.

  4. When moving files around it’s back to loosing 50 to 100 or so files when it compiles - something it used to do infrequently is nearly every time now.

  5. First time ever had insufficient memory warning coming up and more than once.

  6. when selecting album it starts playing but no track list just plays through the album and then the skip backwards button does not work!

Even worse i bricked one of my WDTV’s installing the firmware - total loss tried everything - i’m used to bugs in WD’s updates but this has to be the worst by far.

Guess what, iplayer finished so i have to reboot the wdtv now, if only it was a real doughnut spinning before me i’d be happy then…

only read fat 32 and ntfs?

exfat and mac os X disks nothing…

USB Storage File System Support

  • NTFS
  • FAT/FAT32
  • HFS+    *

Page 7: http://www.wdc.com/wdproducts/library/UM/ENG/4779-705062.pdf

* Media Library process failed:

• the USB device is not using the HFS+ file system
with Journaling enabled.

Page 205

Thought I’d add the problem I’ve experienced.

Cannot play any media on either of my 2 media servers - a Synology NAS & Mezzmo on my PC - or via Windows Shares.

Just get the spinning arrow.

Reverted back to previous version and it all works again.

1 Like

Here’s a new one.  I actually had a video (an MP4) playing, then the video suddenly dropped back to the video list (without me touching anything), while the audio continued to play in the background!

Never had that happen with my WD before, ever, under any firmware.

WileyCoyote wrote:

Here’s a new one.

New?

http://community.wd.com/t5/WD-TV-Live-Streaming/Firmware-2-02-32-Not-playing-all-mp4-files/m-p/778481#U778481

Techflaws wrote:


WileyCoyote wrote:

Here’s a new one.


New?

 

http://community.wd.com/t5/WD-TV-Live-Streaming/Firmware-2-02-32-Not-playing-all-mp4-files/m-p/778481#U778481

New for me, okay?  You knew what I meant.

Of course I do. Searching before posting helps, though.

WD has seriouslly gone down hill over the years i use to always like them and recommend their hardware now i can not think of a reason to do it anymore.

I have retuned hard drives under warranty because they just seem to start dying, ive evn had to replace one because it was dying just out of warranty and grab the sotware off it before its too late. Ive even had the ‘‘joy’’ of sending two NAS units back under warranty because well, yes you guessed it they were dying i then had to buy a replacement plug because it was an american plug can they not tell im in the UK via my address thatg says United Kingdom?

Now it seems like they are too lazy to check a firmware update or even a fix in a decent time, its upto the ‘‘user’’ to visit the forums and look into downgrading because of their incompetence or buy a new unit because some people will think age has kicked in and its well dying.

Yep, will not recommend another WD product to anyone infact i will tell them to look at alternatives, speaking of which i best start looking at another NAS before this one does the same as the other two.

Good luck with that.

Techflaws wrote:

Of course I do. Searching before posting helps, though.

It’s funny, you being so condecending about things and trying to embarass me worked to such an extent I didn’t even bother clicking on that link and looking what was discussed on the other end of it until now.  It doesn’t even lead to the bug you’re claiming it does. It jumps to a post that says “Just upgraded to 2.02.32 and found that many of my mp4 movies wouldn’t play anymore!!!” and not one that mentions files PLAYING but then the video dropping back to the index, with the audio continuing.

Trying to embarrass you? Yeah, I think I’m not gonna bother to go on with you. Have fun finding the right thread.

Hi guys, please try to keep it friendly. @WileyCoyote, we have passed your case to tech support, have you checked your private messages? 

1 Like

jubei04 wrote:

@WileyCoyote, we have passed your case to tech support, have you checked your private messages? 

Thanks, I didn’t even know we had PMs on this board! (the board design here is a bit weird)  Guess I know now.  :-)

I’m not really sure what they can do for me other than possibly talk me through a firmware rollback, but if I know I have a good open block of time for a callback I’ll contact and talk with them for sure.  The interface slowness seems to go back to a memory leak (because rebooting the unit ususally fixes it), and the issues like files where the video drops but the audio continues seem to be widespread, at least if the reaction I got after posting about it meant that I should have realized that (I do have to start paying attention though and see if I can figure out if the ones it happens with for me are all using a common type of encoding).