Firmware 2.02.28 - Australian ABC iView problem

A KB search reveals no trace of 2.02.28. 

I’m posting this here because at the end of my support submission I received the following error:

“An error was encountered during knowledge base search.”

Note:  This issue may not be of interest to anyone other than Australians.

Today I updated my WDTV SMP to the newly released firmware version 2.02.28.

As firmware updates go, this one seemed a bit clunky. It’s split into two sections and I needed to switch from WiFi to a LAN cable to complete part 2.

Now the firmware has been updated I can no longer use the ABC iView application. The app starts, the “working” widget spins once and then the screen turns white. I can return to the menu system by pressing home. As far as I can tell all other apps are functioning as normal.  I can also confirm that the ABC’s system is working using another platform.

I can confirm that the problem persists after both a power cycle and a full reset.

I attempted a rollback to the version available on the support site, 2.01.86, at

but evidently this isn’t possible with the device I have - WDBGXT0000NBK-01 - despite the advice on that page. I can view the contents of the USB drive with it loaded in either USB port but new firmware isn’t detected whilst in operation or when you’d hope it would be, on a restart.

I’d be grateful if someone could advise the correct method to roll back firmware for this model, or alternatively perhaps WD could address the issue with the app.

Where did you get 2.02.28 from ?

Release notes reveal no such Firmware revision ?

Anyways … moving on

If you downloaded 2.01.86 (Which is a valid Firmware) from here …

and the WDTV is not detecting it via USB … then 2 things

  1. Check the Setup > System > Auto Detect New Firmware > On

  2. To force a rollback or 2nd attempt … you will need to edit the  wdtvlivegen3.ver  file to a higher number (use Notepad)

eg. from this


to this


close and “save” and reboot your WDTV & hopefully it will detect it and begin the procedure.

Once it’s all “Done”

Setup > System > Reset All Settings Back to Factory Default

1 Like

Thanks for the reply!

The new firmware was offered online direct to the device which has been the experience for all of the upgrades to date.  Like you I couldn’t find about it here, on WD proper or in the what’s new part of the upgrade dialogue. I haven’t checked if it’s still up…

I changed the version number as you suggested, and whammo, new firmware detected.  I performed the “update” and then reset to factory defaults.  The device rebooted, the old menus were back, the new option in setup vanished…so far so good.

To all intents and purposes the firmware rolled back perfectly.  I had no issues running basic apps like Accuweather or streaming video over my LAN.  

However I still have the iView problem, but now after the brief busy widget my screen goes black instead of white.

I did manage to log a case after registering it, out of warranty as it is and I’ll report back if a solution is found.


Bummer about iView  (Just finished watching “Good Game” … on my PS3 just now ) … so it aint an iView problem

Edit: it “was” an iView fault on ‘some’ devices … see posts below

Thre’s a problem with iView - check the forums. ABC know about it and are attempting to resolve.

I’d done both of those things, no change.  I do know that I have to switch off my transparent proxy to allow it to geolocate properly and to add the iView option.

Exitguy suggests that there is an issue with iView which started on Sunday.

I haven’t watched iView since last week so it’s entirely possible that this is the root cause.  Odd that iView works on my phone and tablet flawlessly…

This is interesting … iView does not work on my Panasonic Smart TV  (Error Message … just checked now 9.40am AEST)

But… Works Fine on my Playstation 3



So, yep definately an iView problem *On Some Devices*


Dave, i would try again on your WDTV in a day or two

1 Like

I have to admit it’s good to know this is a widespread issue not jut a bricked device!

…and (happy dance) at 1250pm AEST 30/7 iView is working on the WDTV.

Now, do I run that firmware update again?? ;p


Thanks for the update Dave, yep works again on the Panasonic Smart TV

Dave2000 wrote:

Now, do I run that firmware update again?? ;p


Well, even though it was iViews fault … at least you know now about editing *.ver files and doing firmware rollbacks

So, some good came out of it  :smiley:

Yes, I’m more used to updates having version numbers embedded in their code like BIOS…still good to know.

Readers of this thread, do you want the good news or the good news?

It seems like 16 hours is a long time in WD land!

I pushed the 2.02.28 update and when it had completed was surprised to see another OTA update offered, ver 2.02.31

Since the ABC have fixed their iView problems and it worked on 2.02.28 I pressed ahead.  Everything seems fine.

This is could well be the update many of us have been waiting for, Miracast is now fully functional and I can stream directly off both my Android phone and tablet.


That’s interesting … hasn’t been announced here

Or here…

And the product page says no miracast

Maybe WD are in the process of updating ?

P.S. Dave, how’s video streaming from your Android Phone/Tablet ?

I’ve played around with Miracast (tablet to tablet) and experienced quite a bit of lag.

Got given a Chromecast a couple of weeks ago and video streaming is perfect (no lag)

Tablet / Phone to Chromecast … Web Streaming and Local files


No idea why they don’t advertise these things, but that update today was 4 revs past the one from yesterday so clearly a work in progress.

Miracast works well, you just have to wait until the phone/tablet **bleep** the DLNA option isn’t the same.  Video, stills and more importantly for anyone doing training, the home screen or active app all appear with imperceptible lag.

For a $49 device - I bought on special at OW and claimed a rebate - it’s still a winner.

BTW is there a way for a moderator to label this issue solved?  Asking for all those poor people trawling the 'net looking for solutions…

This is disappointing. I tried the auto update and all that is available for me is 2.01.86. I am accessing from Australia also. Wonder if the times you update were when they were testing something and it is now withdrawn? 

Not sure why you don’t see updates, I’ve seen two this week alone.

2014-07-31 12.57.18.jpg

my guess is that some regional update server has inadvertantly had beta firmwares added to it