Firmware 1.02.17 first impressions

Updated to 1.02.17, everything went smoothly

Tested ABC iview … works fine

Tested several MP4’s that would’nt play on Firmware 1.01.30 … now play fine with 1.02.17

Watched a couple of Youtube Leanback videos (HD) … pressed the “Home” button to exit, GUI navigation still ok (not sluggish)

Edit: Let Youtube Leanback “Auto Play” for about 15-20 Minutes … exited, and the GUI is sluggish

went to play a video and got the “Low System Memory Warning” selected “No” Don’t Restart …

Video locked up and froze … had to pull the power cord out and reboot  :cry: 

will keep testing … but so far so good  :smiley:

So, it’ll be interesting to see how long it’ll take till the fixed MP4 routine is backported to the Live Streaming…

Im hopeful of a christmas miracle :slight_smile:

So far I’m really happy with it…don’t need to remove the chapters/metadata information with FFMPEG of the mp4 files now. They’re finally played directly by the device!

Need to test more, but so far: nice job!

Even with the positive comments I allowed the update to proceed with some trepidation.  But I’m pleased to say that it seems to be an improvement!  I had several MP4 files that would not play before unless I ran it through a “re-mux” program (suggested on this forum in another thread).  Now those files play just fine eliminating that extra step of re-muxing them.

One thing I did notice that seems to be missing.  When playing a video and then going into X2 fast forward I had noticed that in the previous firmware if you hit the right double arrow (Next Track) it would advance by 10 minutes.  I don’t think this was in the user manual so I’m not sure this was an official feature.  But in this new version this doesn’t seem to work any more.

However I’m willing to trade better file compatibility for an undocumented feature.



The 10 minute “Skip” feature has existed in all WDTV devices since day one.  (My old Gen1 has the feature)

Just now, i tested a few MP4’s … eg.  >> x2  then press  >>I 

It worked fine for me  :smiley:

but … i did notice one thing

it only works when fast fowarding at “x2” speed  :confounded:

I tried doing the “skip” while fast fowarding at x6 x8 etc speeds … and it did’nt work

curious, i decided to test it on my WDTV Live Hub … the “skip” feature works on ALL speeds eg. at x16 speed i can do the >>I 10 minute skip.

Anyways, it looks like there is something “different” but i guess it’s not a total deal breaker :neutral_face:

Just happy the MP4’s are now playing and just have to remember to do the skip at x2 speed only.

Needs Netflix service

Hi JoeySmyth,

I only had a short time to play around with it but I could have sworn that it wouldn’t do the 10 min skip even at the x2 speed.  But I’ll try it again and report back here.

But as I said before even if the skip is gone its still better off being able to play more formats without having to process them further bafore sending them to the WD.


@ Zombat         quote: Needs Netflix service

Not likely anytime soon (or ever)

No Neflix is part of the marketing feature

Hi JoeySmyth,

You are right!  The 10 min skip is still there but only at 2X playback.  I could have sworn that it didn’t do it the first time I tried this new firmware but I tried it several times this morning and it worked just fine.

So far this new firmware seems, at least to me, to be working quite well.


So long waiting and leaves the update when I leave my house for a month. Now I can not prove it. I hope they have fixed all the problems of playing

I only watch stuff off a local USB hard drive.  The problem only started after the mid-December firmware update.  We watch a show (or two or three), go to start the next one and the orange arrow spins forever.  Takes a Device Restart to get it working again.  Have done a Device ReSET once to try to clear it up, without any luck.


Just received a WDTV Media Player for Christmas and have updated firmware to 1.02.17 from the initial 1.00.42 that came on it. I also have a WDTV Live Media Hub purchased in 2010 and love it!!! Got the WDTV Media Player for the bedroom and was a little disappointed that it didn’t have Netflix(yet has vudu???). Yeah, the main reason I got it was to stream movies I have stored on the 2TB USB drive attached to the WDTV Live Media Hub…but the only real “problem” I have encountered on the Media Player is that the 39 apps that are adRise, Inc. apps do not work at all(all other apps seem fine). 26 of the adRise apps give a white blank screen and the other 13 load but hang up on the “…loading” screen whenever you select something to play. It is hard-wired Ethernet to a 15Mbps DSL broadband modem/router and I don’t have any other problems streaming from DirecTV, AppleTV, etc. in my entertainment center. I contacted adRise via their website but no response thus far. Is anyone else able to use these apps???