File System Check Failed Error

I have an EX2 Ultra NAS that is reporting the following error:

File system check has detected errors on your configuration. Backup your data and recreate your drive configuration to resolve these errors. If problem remains, contact WD Support.

I can’t find any details on what is meant by “recreate your drive configuration to resolve these errors.” What exactly does these mean - do I have to go all the way down to actually recreating the RAID configuration - i.e., reformat the drives? Any help appreciated.

Hi CDA_Tech,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support.

Thanks. Actually spoke to them and they suggested returning the unit, but instead I first tried rebuilding the RAID set (didn’t help) and then recreating the RAID set (fixed the scan problem). So that’s resolved.

But there is another issue, which is email notifications stopped working a while ago. This is actually for two different EX 2 units, at different locations. Both stopped sending notifications around the same time. Test email are never received either.

Support sent me a link to a KB article (ID 18340) but nothing in that helped. BTW, a number of typos in that doc…

So at this point, scan issue fixed but notifications not working on two different units at two different sites.

Yes, Yes, Yes, Everyone knows about calling support. This community forum is for those folks that want to share their experiences and potentially keep someone from having to wait on a phone call for an agent that starts their spiel with “is it plugged in”. There are COMMON issues that arise and having solutions that worked listed HERE is valuable to others.